Bug 492629 - Explicit package conflicts on split media installs not found until specific transaction containing them
Explicit package conflicts on split media installs not found until specific t...
Status: CLOSED DUPLICATE of bug 472958
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: 504308 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2009-03-27 14:58 EDT by Jesse Keating
Modified: 2014-01-21 18:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-08 15:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2009-03-27 14:58:42 EDT
This means you could install everything from disc1, disc2, and then get a conflict on disc3 with no good way out.  Explicit conflicts should be found at depcheck.
Comment 1 Jeremy Katz 2009-04-22 11:25:48 EDT
This isn't anything new.

The problem we're going to end up having is that when we build the transaction the only thing we get back is whether or not there's an error plus a list of messages.  That will include both dep problems (which are "okay") and conflicts.  And the only way to tell which we've got would be to parse strings of error messages :/
Comment 2 seth vidal 2009-04-27 10:24:07 EDT
Alternatively, change the rpm bindings so that instead of error strings we get error objects back and can check the object type.
Comment 3 Chris Lumens 2009-05-04 12:16:45 EDT
I don't see how we can possibly get to this in time for F11, given all the storage stuff yet to fix.
Comment 4 Chris Lumens 2009-06-05 10:42:11 EDT
*** Bug 504308 has been marked as a duplicate of this bug. ***
Comment 5 Paul W. Frields 2009-06-06 17:24:24 EDT
Noted on the wiki: https://fedoraproject.org/wiki/Upgrading#Tips

Review and correction of the wiki page is appreciated. :-)
Comment 6 Chris Lumens 2009-06-08 15:32:52 EDT

*** This bug has been marked as a duplicate of bug 472958 ***

Note You need to log in before you can comment on or make changes to this bug.