Bug 472964 - encrypted harddisk: wrong keyboard layout on boot
encrypted harddisk: wrong keyboard layout on boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
: 495698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 15:33 EST by Julian G
Modified: 2009-11-17 18:56 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 18:56:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian G 2008-11-25 15:33:47 EST
Description of problem:
If you set to encrypt you hard disk on installation, it uses the selected keyboard layout to set the password. If you reboot afterwards and it asks for password it uses english keyboard layout.

How reproducible:
Install Fedora 10 with disk encryption and latin1 keyboard layout - use a password with special characters or y/z. After a reboot you'll have to enter your password like on an english keyboard.
  
Actual results:
Boot fails because it can't access hard disk.
Comment 1 Milan Broz 2008-11-25 15:43:44 EST
Installer should set proper keyboard layout in inird, moreover plymouth now read the password, not cryptsetup itself, not sure which package is responsible for that.
Reassigning this to anaconda for now.
Comment 2 Till Maas 2008-12-01 10:43:35 EST
Did you install from DVD or from a live medium? I noticed this problem with the live medium, too. But it worked with a Snap3 installation from DVD. Maybe the initrd is not recreated if a live medium is used.
Comment 3 Julian G 2008-12-08 13:55:38 EST
I've installed from i686 KDE Live CD. After executing /usr/libexec/plymouth/plymouth-update-initrd it seems to be fixed.
Comment 4 Julian G 2009-02-28 06:54:11 EST
this error still occurs with fedora 11 alpha i686 kde live.
Comment 5 Julian G 2009-03-18 19:59:50 EDT
Maybe if someone will ever look at this: would be nice to have this fixed in beta release!!!
Comment 6 Chris Lumens 2009-04-14 09:50:02 EDT
*** Bug 495698 has been marked as a duplicate of this bug. ***
Comment 7 Gian-Carlo Pascutto 2009-04-20 16:04:32 EDT
Fedora 11 x64 Beta DVD
Set Dutch language keyboard layout during installation and initial password entry.
After installation the system defaults to US keyboard layout.


After changing the default in System-Preferences-Keyboard, it still defaults to the wrong one in the login dialog (but there is at least a button to switch it). (Maybe this is a separate bug)
Comment 8 Julian G 2009-04-20 16:27:07 EDT
=> have a look at comment #3
Comment 9 Julian G 2009-05-25 11:06:35 EDT
this bug is still present in f11 i686 preview kde live cd :(
Comment 10 Yaakov Nemoy 2009-06-10 07:23:20 EDT
confirmed present in f11 x86_64 kde live cd, when using the installer and encrypting the entire hard drive.
Comment 11 Yaakov Nemoy 2009-07-15 13:45:20 EDT
Seriously, can anyone use bugzilla properly? This bug has been fixed. Can anyone else here confirm it, or i'll close it in a couple of days.
Comment 12 Andy Lindeberg 2009-07-15 14:37:10 EDT
There's no need to be a jerk about it, dude.
Comment 13 Julian G 2009-09-01 12:03:21 EDT
Bug ist still there in Fedora 12 Alpha i686 KDE Live-CD.
Comment 14 Mikko Huhtala 2009-10-25 16:30:53 EDT
Still there in F12 Beta i686. I did an FTP install onto the hard drive and specified the Finnish layout during installation. The default in Gnome after installation was the US layout.
Comment 15 Mikko Huhtala 2009-10-25 18:00:27 EDT
On F12 Beta, the setting also does not stay put during updates. I set the correct layout for the first session in newly installed F12 Beta, then updated to current Rawhide, and on the next login, the layout was back to the US one. I think there is a bug for the Gnome component that clobbers the setting upon updating somewhere in this Bugzilla, but I cannot find it.
Comment 16 Julian G 2009-10-28 11:05:10 EDT
Bug fixed in Fedora 12 Beta AMD64 KDE Live-CD.
Comment 17 Julian G 2009-11-17 18:56:33 EST
Bug fixed in Fedora 12 AMD64 KDE Live-CD.

Note You need to log in before you can comment on or make changes to this bug.