Bug 472981 - "Error 28: Selected item cannot fit into memory" when booting memtest86+
"Error 28: Selected item cannot fit into memory" when booting memtest86+
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paulo Roma Cavalcanti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 16:54 EST by Cristian Ciupitu
Modified: 2009-05-18 22:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.11-9.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 00:10:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cpuinfo (1.29 KB, text/plain)
2008-11-25 16:54 EST, Cristian Ciupitu
no flags Details
Spec file patch. (2.81 KB, patch)
2009-02-03 17:48 EST, Paulo Roma Cavalcanti
no flags Details | Diff
Modify setup utility for writing "kernel --type=netbsd /memtest86+-2.11" (480 bytes, patch)
2009-02-04 04:19 EST, Paulo Roma Cavalcanti
no flags Details | Diff

  None (edit)
Description Cristian Ciupitu 2008-11-25 16:54:30 EST
Created attachment 324674 [details]
cpuinfo

Description of problem:
I can not run memtest86+ on my machine. 

Version-Release number of selected component (if applicable):
memtest86+-2.01-3.fc9.i386.rpm

How reproducible:
Every time (on my machine).

Steps to Reproduce:
1. Configure grub like this (using memtest-setup):
default=1
timeout=5
splashimage=(hd0,7)/grub/splash.xpm.gz
hiddenmenu
title Memtest86+ (2.01)
        root (hd0,7)
        kernel /memtest86+-2.01 ro root=/dev/hermesVG/rootVol
2. Boot memtest86+

Actual results:
"Error 28: Selected item cannot fit into memory"

Expected results:
memtest86+ should boot and run

Additional info:
I'm using grub-0.97-33.fc9.i386.rpm.
My hardware is: 6400 Core 2 Duo CPU with an Intel 965LT motherboard and 1 GB of RAM. The BIOS has the default optimal settings with minimal tweaking (ACHI, serial port disabled etc.).
Comment 1 Warren Togami 2008-11-25 18:32:40 EST
http://kojipkgs.fedoraproject.org/packages/memtest86+/2.10/

Could you please test this newer version?
Comment 2 Cristian Ciupitu 2008-11-26 09:46:26 EST
I've installed that package by doing:
  rpm -ivh http://kojipkgs.fedoraproject.org/packages/memtest86+/2.10/1.fc9/i386/memtest86+-2.10-1.fc9.i386.rpm
and I'm still getting "Error 28: Selected item cannot fit into memory".
Comment 3 Cristian Ciupitu 2008-11-26 09:47:49 EST
PS: Btw, I was able to *install* the new package, even if the old package was still installed. I was able to have both packages installed at the same time.
Comment 4 Warren Togami 2008-11-26 18:13:33 EST
Parallel install is not a bug, it is essentially like kernel, without a userspace.

Are you sure you added it to your grub boot menu and you are not booting the old version?
Comment 5 Cristian Ciupitu 2008-11-26 18:58:28 EST
Yes, I'm very sure that I booted the new (recommended) version. I have double checked, before replying here :-)

PS: I'll install Fedora 10 in the next hours or days, so I won't be able to test anything on Fedora 9, but on the other hand I doubt there's a relation between (the version of) Fedora and memtest86+.
Comment 6 Paulo Roma Cavalcanti 2009-01-07 05:19:21 EST
This .src.rpm works for me:

http://people.atrpms.net/~pcavalcanti/srpms/memtest86+-2.11-3.fc10.src.rpm


Please, see also:

https://bugzilla.redhat.com/show_bug.cgi?id=237279


when I tried to fix this bug a long time ago.
Comment 7 Warren Togami 2009-01-16 19:05:26 EST
I see.  I don't understand this boot stuff too well, and I've personally never had a problem booting from grub.  I'll ask someone else to review your changes.
Comment 8 David Shaw 2009-01-31 13:25:13 EST
I can confirm this problem still exists on F10 with memtest86+-2.10-1.fc10.i386
Comment 9 Cristian Ciupitu 2009-01-31 13:31:15 EST
Yeah, I still have the problem on Fedora 10. Could someone please duplicate or change this bug to Fedora 10?
Comment 10 Paulo Roma Cavalcanti 2009-01-31 14:30:11 EST
Can anyone try this rpm for F10 x86_64?

http://people.atrpms.net/~pcavalcanti/rpms/rpms10-x86_64/memtest86+-2.11-3.fc10.x86_64.rpm

It works for me.
Comment 11 Warren Togami 2009-02-03 14:10:05 EST
Could you please submit changes to upstream memtest86+ project?

hansg recommended making you the co-maintainer of memtest86+.  Do you already have a Fedora developer account with packager status?
Comment 12 Paulo Roma Cavalcanti 2009-02-03 17:48:07 EST
Created attachment 330792 [details]
Spec file patch.
Comment 13 Paulo Roma Cavalcanti 2009-02-03 17:51:06 EST
(In reply to comment #11)
> Could you please submit changes to upstream memtest86+ project?
> 
> hansg recommended making you the co-maintainer of memtest86+.  Do you already
> have a Fedora developer account with packager status?

Yes:

http://koji.fedoraproject.org/koji/userinfo?userID=866

My sponsor is Jon Ciesla.




I also created a patch for adapting the current Fedora spec file.

Although I did not use 

Patch0: memtest86+-2.10-fixflags.patch

this was not the point. It can be used if needed.
Comment 14 Paulo Roma Cavalcanti 2009-02-04 04:19:53 EST
Created attachment 330842 [details]
Modify setup utility for writing "kernel --type=netbsd /memtest86+-2.11"
Comment 15 Fedora Admin XMLRPC Client 2009-03-10 21:15:38 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Fedora Update System 2009-03-13 16:19:51 EDT
memtest86+-2.11-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/memtest86+-2.11-4.fc10
Comment 17 Fedora Update System 2009-03-13 16:19:57 EDT
memtest86+-2.11-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/memtest86+-2.11-4.fc9
Comment 18 Fedora Update System 2009-03-16 15:48:31 EDT
memtest86+-2.11-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2753
Comment 19 Fedora Update System 2009-03-16 15:53:07 EDT
memtest86+-2.11-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2776
Comment 20 Fedora Update System 2009-03-31 11:14:43 EDT
memtest86+-2.11-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/memtest86+-2.11-5.fc10
Comment 21 Fedora Update System 2009-03-31 11:14:54 EDT
memtest86+-2.11-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/memtest86+-2.11-5.fc9
Comment 22 Fedora Update System 2009-04-02 13:16:15 EDT
memtest86+-2.11-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3222
Comment 23 Fedora Update System 2009-04-02 13:18:35 EDT
memtest86+-2.11-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3257
Comment 24 Fedora Update System 2009-04-03 08:20:42 EDT
memtest86+-2.11-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/memtest86+-2.11-6.fc10
Comment 25 Fedora Update System 2009-04-03 08:20:56 EDT
memtest86+-2.11-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/memtest86+-2.11-6.fc9
Comment 26 Fedora Update System 2009-04-12 07:29:26 EDT
memtest86+-2.11-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/memtest86+-2.11-7.fc10
Comment 27 Fedora Update System 2009-04-12 07:29:45 EDT
memtest86+-2.11-7.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/memtest86+-2.11-7.fc9
Comment 28 Fedora Update System 2009-04-13 15:33:12 EDT
memtest86+-2.11-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3511
Comment 29 Fedora Update System 2009-04-13 15:34:59 EDT
memtest86+-2.11-7.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3526
Comment 30 Fedora Update System 2009-04-27 17:27:48 EDT
memtest86+-2.11-9.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3526
Comment 31 Fedora Update System 2009-04-27 17:28:55 EDT
memtest86+-2.11-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update memtest86+'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3511
Comment 32 Fedora Update System 2009-05-12 00:09:54 EDT
memtest86+-2.11-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2009-05-18 22:05:52 EDT
memtest86+-2.11-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.