Bug 473001 - system-config-network saves invalid NETMASK in ifcfg-eth0 file
system-config-network saves invalid NETMASK in ifcfg-eth0 file
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 19:01 EST by Stephen Warren
Modified: 2008-11-27 07:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 07:45:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2008-11-25 19:01:05 EST
Description of problem:
Run system-config-network, edit the configuration for eth0, assign a static IP, e.g.:

Address: 10.20.204.52
Subnet mask: 255.255.254.0
Default gateway address: 10.20.204.1

Save the updated configuration. Now, view /etc/sysconfig/networking/profiles/default/ifcfg-eth0, and see that the gateway value has the wrong data (I think it's just a duplicate of the gateway field from memory).

Version-Release number of selected component (if applicable):
system-config-network-1.5.93-2.fc10.noarch

How reproducible:
Always
Comment 1 Pavel Rosenboim 2008-11-27 03:57:22 EST
I have the same problem. Netmask gets overwritten with value of gateway address.
Comment 2 Pavel Rosenboim 2008-11-27 05:04:18 EST
I have the same problem. Netmask is overwritten by value of default gateway.
Comment 3 Jiri Moskovcak 2008-11-27 07:45:21 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.