Bug 473065 - Preupgrade conflicts with bad yaboot release
Summary: Preupgrade conflicts with bad yaboot release
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: preupgrade
Version: 10
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 472990 474352 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-11-26 13:28 UTC by Roman Rakus
Modified: 2014-01-21 23:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-07 09:08:19 UTC
Type: ---


Attachments (Terms of Use)

Description Roman Rakus 2008-11-26 13:28:45 UTC
Description of problem:
preupgrade conlicts with yaboot-1.3.14-8, but latest was release 6. I do release 7 in which is long append fixed. But still don't go through conflict check. There should be
Conflict: yaboot < 1.3.14-7

Or is there any reason why is there -8 release check?

Comment 1 Will Woods 2008-11-26 21:12:11 UTC
Yes; David Woodhouse built yaboot-1.3.14-8.fc10 to fix bug 471321 (long append) and bug 471425 (ybin --bootonce). To avoid breaking upgrade paths, the Rawhide build needs to be >= 1.3.14-8 - so you should probably bump the release number and rebuild.

But for this to actually help preupgrade on ppc, we also need new yaboot builds for F8 and F9. Current yaboot versions there are yaboot-1.3.13-12.fc9 and yaboot-1.3.13-8.fc8. Ideally we should be able to rebuild yaboot-1.3.14-8 for F8 and F9, but if that's not possible, I think I can do a conditional Conflicts: depending on the distribution version. Just let me know the version number for the fixed packages and I'll change preupgrade.

Comment 2 Will Woods 2008-11-26 21:22:14 UTC
*** Bug 472990 has been marked as a duplicate of this bug. ***

Comment 3 Roman Rakus 2008-11-27 16:03:34 UTC
So:
rawhide: yaboot-1.3.14-8.fc11
F-8: yaboot-1.3.13-9.fc8
F-9: yaboot-1.3.13-13.fc9

In all of them included patch increasing MAX_TOKEN. OK?

Comment 4 Will Woods 2008-11-27 23:40:31 UTC
This will be fixed in the next build of preupgrade.

Comment 5 Will Woods 2008-12-03 20:49:27 UTC
*** Bug 474352 has been marked as a duplicate of this bug. ***

Comment 6 Alex Kanavin 2008-12-10 15:55:27 UTC
I keep getting "preupgrade conflicts with yaboot" popups on my F10 desktop, and update applet doesn't seem to work. When will those updated yaboot packages be available?

Comment 7 Roman Rakus 2008-12-10 16:02:37 UTC
I should push them in bodhi, maybe. Or you can test them and give them karma.

Comment 8 Alex Kanavin 2008-12-10 16:12:00 UTC
Sure I can test if you tell me where to find the F10 package.

Comment 9 Roman Rakus 2008-12-11 09:47:57 UTC
Now it should be in bodhi.

Comment 10 Roman Rakus 2008-12-11 09:49:08 UTC
To complete comment #3:
F-10: yaboot-1.3.14-8.fc10

Comment 11 Will Woods 2008-12-15 22:36:55 UTC
yaboot updates have been pushed and a new preupgrade package has been built. 

preupgrade-1.0.1 should hit updates-testing shortly.

Comment 12 Fedora Update System 2008-12-16 22:35:33 UTC
preupgrade-1.0.1-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc8

Comment 13 Fedora Update System 2008-12-16 22:38:17 UTC
preupgrade-1.0.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc9

Comment 14 Fedora Update System 2008-12-16 22:38:34 UTC
preupgrade-1.0.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc10

Comment 15 Fedora Update System 2008-12-21 08:22:49 UTC
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-11587

Comment 16 Fedora Update System 2008-12-21 08:37:57 UTC
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11540

Comment 17 Fedora Update System 2008-12-21 08:45:35 UTC
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11437

Comment 18 Fedora Update System 2009-01-07 09:07:31 UTC
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2009-01-07 09:08:02 UTC
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2009-01-07 09:24:05 UTC
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.