This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 473117 - VIA CHROME9 support in F10 Live CD doesn't work
VIA CHROME9 support in F10 Live CD doesn't work
Status: CLOSED DUPLICATE of bug 446489
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 11:03 EST by Marcus D. Leech
Modified: 2008-12-29 15:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 15:53:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file from Ubuntu 8.04.1 LTS with working VIA CHROME 9 support (1.44 KB, text/plain)
2008-11-26 20:35 EST, Marcus D. Leech
no flags Details
Xorg server log filet from Ubuntu system with working VIA CHROME 9 support (59.94 KB, text/plain)
2008-11-26 20:37 EST, Marcus D. Leech
no flags Details
Post-removal of xorg.conf log of autoconfed X11 startup (63.29 KB, text/plain)
2008-11-26 20:58 EST, Marcus D. Leech
no flags Details

  None (edit)
Description Marcus D. Leech 2008-11-26 11:03:35 EST
I have an Everex VA1500V laptop, which sports a VIA Chrome9 series video
  chipset.  I can't get the F10 installer or Live CD to work, since there are
  severe rendering problems.  Curiously, the F10 "Blue Sun" background renders
  properly, but other elements (the window that pops up in the middle) doesn't
  render, and the mouse freezes.

The Laptop came with gOS on it, which works fine, and an upgrade to gOS 3 also
  works fine--gOS 3 is based on Ubuntu 8.04.1 LTS.  This apparently uses the
  OPENCHROME X driver dated January 23rd, 2008.

The particular chipset identified in Xorg.0.log by the OPENCHROME driver
  in Ubuntu/gOS is:

Chipset P4M900/VN896/CN896  found

I'm a Fedora man, though and through, and I'd really like F10 to work on my
  shiny-new (and cheap!) laptop.

I'll observe that the F9 installer suffered identical problems to F10 in this
  regard, so the problem has been around for awhile.
Comment 1 Matěj Cepl 2008-11-26 18:38:27 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Marcus D. Leech 2008-11-26 20:35:17 EST
Created attachment 324813 [details]
xorg.conf file from Ubuntu 8.04.1 LTS with working VIA CHROME 9 support
Comment 3 Marcus D. Leech 2008-11-26 20:37:24 EST
Created attachment 324814 [details]
Xorg server log filet from Ubuntu system with working VIA CHROME 9 support
Comment 4 Marcus D. Leech 2008-11-26 20:39:22 EST
Keep firmly in mind that the attachments are from a Ubuntu system, and
  not a Fedora system (since I can't get either F9 or F10 to even run
  the installer on this system, due to severe video/X11 problems).
Comment 5 Marcus D. Leech 2008-11-26 20:58:55 EST
Created attachment 324815 [details]
Post-removal of xorg.conf log of autoconfed X11 startup
Comment 6 Warren Togami 2008-11-27 00:42:27 EST
That Ubuntu log is showing that it is the openchrome driver, which Fedora also uses.  The log says openchrome version 0.2.901 while Fedora 10 has 0.2.903.  Fedora 9 shipped with 0.2.902, even newer than the Ubuntu version.

Probably your best bet would be to talk to the Fedora openchrome maintainer.  Reassigning.
Comment 7 Xavier Bachelot 2008-11-27 06:57:46 EST
You are possibly hitting an XAA bug/regression that shows up with xorg server 1.5 (your ubuntu logs show xserver 1.4, Fedora >= 9 is using xserver 1.5). Please try to add the following line to the device section of your xorg.conf :
Option "XaaNoImageWriteRect"
Comment 8 Marcus D. Leech 2008-11-27 10:22:18 EST
I would do that, except that I'm running into this on both the Install and
  Live CD for F9 and F10.
Comment 9 Dave Cheney 2008-12-04 08:41:16 EST
I'm hitting this right now trying to install on a HP 2133 Mininote (via PM900 I think)

Standard problems with this driver, corrupted hardware cursor, hanging once x has booted. I've got the live CD working by adding 

vga=791 3

to the boot line, which takes me to init 3, then 

rm /usr/lib/xorg/modules/drivers/openchrome_drv.so

to remove the openchrome driver so it isn't detected (possibly overkill)

then 

init 5

to boot to the live CD.

I hope that I can write a parsable xorg config once the live cd is installed.
Comment 10 Xavier Bachelot 2008-12-04 08:48:17 EST
(In reply to comment #9)
> I'm hitting this right now trying to install on a HP 2133 Mininote (via PM900 I
> think)
> 
> Standard problems with this driver, corrupted hardware cursor, hanging once x
> has booted.

This is known and there is a workaround, see a few comments above. The Option "XaaNoImageWriteRect" workaround should help for the hang.

The hardware cursor problem is known too, I'll push a new build with hardware cursor disabled by default to workaround this.
Comment 11 Dave Cheney 2008-12-04 08:54:27 EST
Thanks for the response, I got through the install and the first boot with the hacks above. I'm going to copy over my working xconfig from Ubuntu 8.10 which has the proper hacks to make OpenChrome work under X 1.5

fwi, I can already tell that F10 is faster than Ubuntu 8.10. I have no idea what they did to the window manager, but it was dog slow.
Comment 12 Xavier Bachelot 2008-12-29 15:53:59 EST

*** This bug has been marked as a duplicate of bug 446489 ***

Note You need to log in before you can comment on or make changes to this bug.