Bug 473136 - Systems with mirrored LVM drives do need labeling
Systems with mirrored LVM drives do need labeling
Status: CLOSED UPSTREAM
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2008-11-26 13:24 EST by Josh Cogliati
Modified: 2008-12-06 05:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 05:31:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Cogliati 2008-11-26 13:24:53 EST
In the release notes section 2.1.4.2 for Fedora 10, it says "Systems that use Logical Volume Management (LVM) and the device mapper usually do not require relabeling."  This is incorrect if you have a mirrored LVM partition, since the UUID for the mirrored partition is not unique:

/dev/mapper/VolGroup00-lvol0_mimage_1: UUID="c9bee71a-ebda-4357-a509-cd92e4a60697" SEC_TYPE="ext2" TYPE="ext3" 
/dev/mapper/VolGroup00-lvol0_mimage_0: UUID="c9bee71a-ebda-4357-a509-cd92e4a60697" SEC_TYPE="ext2" TYPE="ext3" 
/dev/mapper/VolGroup00-lvol0: UUID="c9bee71a-ebda-4357-a509-cd92e4a60697" TYPE="ext3" LABEL="mirrored" SEC_TYPE="ext2" 

If there is no label, with the UUID mount can pick up one of the mirror images (lvol0_mimage_1 or lvol0_migage_0) which will fail.  

This is probably a bug in blkid or anaconda as well, so I will file one under blkid.  

For the release notes, it should probably mention that mirrored LVM partitions do need to be labeled.
Comment 1 Karsten Wade 2008-12-06 05:31:28 EST
Regardless of a bug in blkid/anaconda, they still have identical UUIDs, so it is worth specifying to use labels in that case.  Fixed and should appear in the next update (web and/or fedora-release-notes update.)

Note You need to log in before you can comment on or make changes to this bug.