This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 473145 - netmask garbled by system-config-network
netmask garbled by system-config-network
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-26 14:19 EST by Len Brown
Modified: 2008-11-28 06:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-28 06:42:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Len Brown 2008-11-26 14:19:19 EST
FC10 32-bit on an Asus Eee Box.

Start with a stock DHCP setup:

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
DEVICE=eth0
HWADDR=00:22:15:53:63:c8
ONBOOT=yes
BOOTPROTO=dhcp
USERCTL=no
PEERDNS=yes
IPV6INIT=no
NM_CONTROLLED=yes
TYPE=Ethernet

Then switch to a static IP via the GUI:

# usr/bin/system-config-network

click Statically set IP addresses:
Address: 192.168.0.162
Subnet mask: 255.255.255.0
Default gateway: 192.168.0.1
OK
File/Save

# cat /etc/sysconfig/network-scripts/ifcfg-eth0

# Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
DEVICE=eth0
HWADDR=00:22:15:53:63:c8
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
PEERDNS=yes
IPV6INIT=no
NM_CONTROLLED=yes
TYPE=Ethernet
NETMASK=192.168.0.1
IPADDR=192.168.0.162
GATEWAY=192.168.0.1

and you'll notice that the GATEWAY address has been
saved in the NETMASK address, rather than the requested 255.255.255.0

manual editing ifcfg-eth0 is necessary to recover from
the mistake made by the GUI.
Comment 1 Jiri Moskovcak 2008-11-28 06:42:03 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.