Bug 473186 - Conflict with coreutils
Conflict with coreutils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netatalk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
: 474486 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2008-11-26 18:38 EST by Michael Schwendt
Modified: 2018-04-11 06:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 12:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-26 18:38:07 EST
4:netatalk-2.0.3-21.fc10.i386  in  rawhide-development-i386
  File conflict with: coreutils-7.0-3.fc11.i386
     /usr/bin/timeout
     /usr/share/man/man1/timeout.1.gz
Comment 1 Matěj Cepl 2008-11-28 14:47:49 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 2 Jiri Skala 2009-01-06 04:18:36 EST
*** Bug 474486 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Keating 2009-01-18 11:28:24 EST
Adding ovasik as the maintainer of coreutils.  Timeout just showed up in the latest versions of coreutils, so technically it was coreutils that introduced the problem.  Ovasik?
Comment 4 Ondrej Vasik 2009-01-19 08:10:10 EST
We discussed the issue with jskala ~2 months ago. Both utilities seems to be almost the same (just a few rare exceptions like signal aliases and few extensions on the side of coreutils's timeout) - so on the system with coreutils, nothing will be broken if the name of netatalk utility will change. Changing the name of coreutils's timeout utility could break between-distros scripts - as coreutils are more frequent in use than netatalk. Coreutils's timeout is also more complex - it allows usage of suffixes (you don't have to use `timeout 3600 foo` - you could use `timeout 1h foo`). 

Conclusion was to rename netatalk utility to something like net-timeout and to check for existence /usr/bin/timeout in the post section. When the /usr/bin/timeout not found, symlink will be created ... and removed in postun section when uninstalling and still symlink (installation of coreutils will replace possible existing symlink with real file, so that file should be kept). I don't see anything more simple - as the timeout was accepted to coreutils and I expect it would be kept there in future.
Comment 5 Jesse Keating 2009-01-21 14:52:36 EST
We've decided that this isn't a Alpha blocking bug, but we want it fixed before Beta.
Comment 6 Hans de Goede 2009-01-21 15:06:22 EST
Hmm the proposed fix in comment 4 is too ugly for words, creating symlinks in %post ? No please. This would not pass a package review, so we should not be doing it post review, this is not acceptable IMHO.

coreutils is something which is almost always installed, so if the coreutils timeout is a better more complete implementation, why not just remove the implementation from netatalk ?

And make netatalk Require coreutils to make sure there will always be *a* timeout installed when netatalk is installed (although I wish people good luck with removing coreutils in the first place).

Jiri if you want I can make these changes for you, just say so, then we get this fixed before the alpha.
Comment 7 Ondrej Vasik 2009-01-22 02:21:51 EST
Yes, I know symlinks are ugly solution, but I thought Jiri don't want to add versioned Requires for coreutils - as there may be systems with busybox using that package. If it is acceptable to require coreutils, it is of course much better solution. If some of the signal aliases from netatalk timeout are not present in coreutils timeout, they could be proposed to coreutils upstream.
Comment 8 Jiri Skala 2009-01-26 12:18:14 EST
The timeout is now in the subpackage together with man page of timeout utility. If the system doesn't contain coreutils the netatalk-timeout shall be installed otherwise the timeout of coreutils is used.

Note You need to log in before you can comment on or make changes to this bug.