Bug 47319 - graphical installer should use mtrr.
Summary: graphical installer should use mtrr.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-04 17:33 UTC by Ed McKenzie
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-04 21:55:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-07-04 17:33:25 UTC
Currently, the graphical installer is exceptionally slow, and a big part of
the reason is that mtrr wasn't enabled in the -boot kernel.  Now that it is
(see bug 47296), anaconda should take advantage of it.

(IIRC, XFree86 3.x doesn't do this automatically for fbdev devices.  I
could be wrong.)

Comment 1 Brent Fox 2001-07-06 18:48:00 UTC
The installer uses XFree86 4 if it can.  I'm not sure whether XFree 4 user mtrr
by default or not.  If it does, then the problem should already be fixed.

Comment 2 Brent Fox 2001-07-11 01:39:09 UTC
Seems like this is more of an X problem than an installer problem.  Changing
component.

Comment 3 Mike A. Harris 2001-07-16 06:43:39 UTC
This is not an X problem.  XFree86 uses MTRR if it is available.  If
it is not available then it is not built into the kernel.  I am reassigning
to the kernel component, however IMHO it is just unneeded code bloat in
the boot kernel.  I'll leave that decision up to the kernel team though.

Comment 4 Arjan van de Ven 2001-07-18 09:27:59 UTC
It's not that big, so I enabled it, as a "feel" speedup of the installer is
worth it imho.

Note: we need /proc mounted for this to actually work. Does the installer have
this ? (I assume so)

Comment 5 Ed McKenzie 2001-07-18 12:21:47 UTC
Yes, /proc is mounted during install.

Comment 6 Arjan van de Ven 2001-08-03 12:10:57 UTC
Does the roswell installer have this ?
(I find it hard to judge on my machines)

Comment 7 Ed McKenzie 2001-08-03 14:08:53 UTC
I'll install roswell this weekend and report my findings here.

Comment 8 Ed McKenzie 2001-08-04 21:55:38 UTC
Roswell is better.  Scroll views no longer suck. :)


Note You need to log in before you can comment on or make changes to this bug.