Bug 473247 - Error during installation on multiple RAID1 volumes.
Error during installation on multiple RAID1 volumes.
Status: CLOSED DUPLICATE of bug 468431
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 06:04 EST by Krzysztof Wojcik
Modified: 2009-06-20 04:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 10:17:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shots (354.28 KB, application/x-zip-compressed)
2008-11-27 06:04 EST, Krzysztof Wojcik
no flags Details

  None (edit)
Description Krzysztof Wojcik 2008-11-27 06:04:27 EST
Created attachment 324861 [details]
Screen shots

Description: 
Error during RH 5.3 Snap 3 installation on multiple RAID1 volumes.

Steps to reproduce:
1. Create 2xRAID1 in OROM. Use default settings.
2. Boot RH from DVD
3. Choose New Installation. Use default settings on all pages. 
4. On Suggested Partitioning page use one from two configured RAID's  for installation. 
5. Sometimes there is error message when installer wants to format RAID volume. Look at attachment.

Expected results:
RH correctlly installed. OS is starting and working fine.

Actual results:
Error message when installer wants to format raid volume.

Print sreen's in attachment.

Environment Details:
-OS: RHEL5.3-Server-20081113.1-i386-DVD.iso
-Chipset: ICH9
-CRB: Intel DQ35JO
dmraid version: 1.0.0.rc13 (2007.09.17) debug
dmraid library version: 1.0.0.rc13 (2006.09.17)
device-mapper version: 4.11.5
Comment 1 Hans de Goede 2008-12-02 06:29:13 EST
Hi Krzysztof,

I know you've been doing testing with dmraid and I assume you are interested in ensuring that dmraid works.

The problem you are seeing now is not dmraid related, but is caused by the disks having been used before and both of them having a volumegroup on them with an identical volumegroup name.

For the dmraid testing you want to do you can workaround this by clearing lvm info from the disks before trying to use the:

1) Start the installer
2) Got to virtual console 2 (ctrl-alt-del), where you will find a command
   prompt
3) run "dd if=/dev/zero of=/dev/mapper/XXXXX bs=1024 count=1024"
   For each XXXXXX under /dev/mapper (you can skip the ones representing
   the whole raid set, but this needs to be done for every partition)
4) Reboot

Now you should be able to install without issues. Note that you will still hit
bug 473244, and thus the mirrors will be seen as 2 separate disks after boot unless you use the workaround given in bug 473244, or wait for snapshot5.

Please let us know how things go once you've cleared the lvm data, and are using either the workaround or snapshot5.
Comment 3 Denise Dumas 2008-12-11 09:05:41 EST
Krzysztof, any update on this? Is there a repeatable problem here as of Snapshot5?
Comment 4 Jacek Danecki 2008-12-11 09:52:38 EST
(In reply to comment #3)
> Krzysztof, any update on this? Is there a repeatable problem here as of
> Snapshot5?

We can't reproduce this bug on snapshot 5. We will re-test this on snapshot 6.
If problem reproduces on snap 6, we will create new bug.
Comment 5 Denise Dumas 2008-12-11 10:17:06 EST
Thanks very much, Jacek. I'm going to close this as a dup of 468431.

*** This bug has been marked as a duplicate of bug 468431 ***

Note You need to log in before you can comment on or make changes to this bug.