Bug 473322 - s-c-n writes GATEWAY or IP value into NETMASK in ifcfg-eth0 for static IP
s-c-n writes GATEWAY or IP value into NETMASK in ifcfg-eth0 for static IP
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-27 12:49 EST by Charlie
Modified: 2008-11-28 06:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-28 06:40:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Charlie 2008-11-27 12:49:53 EST
Description of problem:
s-c-n writes GATEWAY or IP into NETMASK in /etc/sysconfig/network-scripts/ifcfg-eth0

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. open GUI
2. Select eth0, if static IP already just save and examine file
3. Edit eth0 to be static, enter addresses and netmask
4. Save
Actual results:
NETMASK=either IP or GATEWAY value

Expected results:
Correctly entered mask

Additional info:
If you hand edit the /etc/sysconfig/network-scripts/ifcfg-eth0 file to the correct values, open with GUI and just save unchanged it overwrites the NETMASK.
Comment 1 Charlie 2008-11-27 12:56:37 EST
The only workaround is to hand edit the /etc/sysconfig/network-scripts/ifcfg-eth0 file.  Also some confusion on the "managed by NetManager" flag.  Should it be yes or no as the default seems to be no, but then NetManager complains it can't start the network.

I think this is also affecting the install when it asks for a static IP/mask and gateway.  I enter the correct info (192.168.1.nn/ where nn is some address on my net and get the "FAILED to start eth0" popup.
Comment 2 Jiri Moskovcak 2008-11-28 06:40:45 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.