Bug 473340 - new f10 issue drm/radeon errors on resume after suspend... screen corruption, not in f9,f8
new f10 issue drm/radeon errors on resume after suspend... screen corruption,...
Status: CLOSED DUPLICATE of bug 473195
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 473971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 16:10 EST by David Campbell
Modified: 2009-05-16 13:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 01:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nomodeset (925 bytes, application/octet-stream)
2009-05-16 13:39 EDT, tmgrrd
no flags Details

  None (edit)
Description David Campbell 2008-11-27 16:10:20 EST
Description of problem:

The radeon driver in f8 works fine with suspend/resume, but on f10 is broken, with screen corruption.  System is up, but is unusable after suspend/resume due to corruption...you can't read what is on the scren.

dmesg reports:
[drm:radeon_resume] *ERROR* 

Taking the system down a runlevel and back...restarting X doesn't make the problem go away.

Screen corruption as in http://www.aaa.net.au/campbell/fedora.png but the screenshot doesn't include horizontal patterns across the screen as screenshot doesn't save them.

Hardware is mobility radeon 9700.

Version-Release number of selected component (if applicable):

Linux clevo 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux

How reproducible:

Always

Steps to Reproduce:
1. Suspend
2. Resume
3. See screen corruption, visible fonts and horizontal patterns across screen (horizontal patterns don't save to screenshot)
  
Actual results:


Expected results:


Additional info:


Nov 27 01:10:50 localhost kernel: CPU1 is down
Nov 27 01:10:50 localhost kernel: x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
Nov 27 01:10:50 localhost kernel: Intel machine check architecture supported.
Nov 27 01:10:50 localhost kernel: Intel machine check reporting enabled on CPU#0.
Nov 27 01:10:50 localhost kernel: CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
Nov 27 01:10:50 localhost kernel: CPU0: Thermal monitoring enabled
Nov 27 01:10:50 localhost kernel: Enabling non-boot CPUs ...
Nov 27 01:10:50 localhost kernel: SMP alternatives: switching to SMP code
Nov 27 01:10:50 localhost kernel: Booting processor 1/1 ip 6000
Nov 27 01:10:50 localhost kernel: Initializing CPU#1
Nov 27 01:10:50 localhost kernel: Calibrating delay using timer specific routine.. 6400.28 BogoMIPS (lpj=3200140)
Nov 27 01:10:50 localhost kernel: CPU: Trace cache: 12K uops, L1 D cache: 8K
Nov 27 01:10:50 localhost kernel: CPU: L2 cache: 512K
Nov 27 01:10:50 localhost kernel: CPU: Physical Processor ID: 0
Nov 27 01:10:50 localhost kernel: Intel machine check architecture supported.
Nov 27 01:10:50 localhost kernel: Intel machine check reporting enabled on CPU#1.
Nov 27 01:10:50 localhost kernel: CPU1: Intel P4/Xeon Extended MCE MSRs (12) available
Nov 27 01:10:50 localhost kernel: CPU1: Thermal monitoring enabled
Nov 27 01:10:50 localhost kernel: x86 PAT enabled: cpu 1, old 0x7040600070406, new 0x7010600070106
Nov 27 01:10:50 localhost kernel: CPU1: Intel(R) Pentium(R) 4 CPU 3.20GHz stepping 09
Nov 27 01:10:50 localhost kernel: checking TSC synchronization [CPU#0 -> CPU#1]: passed.
Nov 27 01:10:50 localhost kernel: CPU1 is up
Nov 27 01:10:50 localhost kernel: ACPI: Waking up from system sleep state S3
Nov 27 01:10:50 localhost kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode
Nov 27 01:10:50 localhost kernel: uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Nov 27 01:10:50 localhost kernel: usb usb2: root hub lost power or was reset
Nov 27 01:10:50 localhost kernel: uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
Nov 27 01:10:50 localhost kernel: usb usb3: root hub lost power or was reset
Nov 27 01:10:50 localhost kernel: uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
Nov 27 01:10:50 localhost kernel: usb usb4: root hub lost power or was reset
Nov 27 01:10:50 localhost kernel: uhci_hcd 0000:00:1d.3: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Nov 27 01:10:50 localhost kernel: usb usb5: root hub lost power or was reset
Nov 27 01:10:50 localhost kernel: ehci_hcd 0000:00:1d.7: PCI INT D -> GSI 23 (level, low) -> IRQ 23
Nov 27 01:10:50 localhost kernel: ata_piix 0000:00:1f.1: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Nov 27 01:10:50 localhost kernel: Intel ICH 0000:00:1f.5: PCI INT B -> GSI 17 (level, low) -> IRQ 17
Nov 27 01:10:50 localhost kernel: ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 filtered out
Nov 27 01:10:50 localhost kernel: ata1.00: ACPI cmd ef/03:42:00:00:00:a0 filtered out
Nov 27 01:10:50 localhost kernel: ata1.00: configured for UDMA/33
Nov 27 01:10:50 localhost kernel: Intel ICH Modem 0000:00:1f.6: PCI INT B -> GSI 17 (level, low) -> IRQ 17
Nov 27 01:10:50 localhost kernel: yenta_cardbus 0000:03:00.0: power state changed by ACPI to D0
Nov 27 01:10:50 localhost kernel: firewire_core: skipped bus generations, destroying all nodes
Nov 27 01:10:50 localhost kernel: pata_pdc202xx_old 0000:03:02.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Nov 27 01:10:50 localhost kernel: r8169 0000:03:03.0: wake-up capability disabled by ACPI
Nov 27 01:10:50 localhost kernel: r8169 0000:03:03.0: PME# disabled
Nov 27 01:10:50 localhost kernel: b43-pci-bridge 0000:03:04.0: enabling device (0000 -> 0002)
Nov 27 01:10:50 localhost kernel: b43-pci-bridge 0000:03:04.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
Nov 27 01:10:50 localhost kernel: parport_pc 00:0a: activated
Nov 27 01:10:50 localhost kernel: serial 00:0b: activated
Nov 27 01:10:50 localhost kernel: ata4.00: configured for UDMA/100
Nov 27 01:10:50 localhost kernel: sd 5:0:0:0: [sdg] 195371568 512-byte hardware sectors (100030 MB)
Nov 27 01:10:50 localhost kernel: sd 5:0:0:0: [sdg] Write Protect is off
Nov 27 01:10:50 localhost kernel: sd 5:0:0:0: [sdg] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov 27 01:10:50 localhost kernel: firewire_core: created device fw0: GUID 0090f5000038124e, S400
Nov 27 01:10:50 localhost kernel: ata3.00: configured for UDMA/100
Nov 27 01:10:50 localhost kernel: sd 4:0:0:0: [sdf] 117210240 512-byte hardware sectors (60012 MB)
Nov 27 01:10:50 localhost kernel: sd 4:0:0:0: [sdf] Write Protect is off
Nov 27 01:10:50 localhost kernel: sd 4:0:0:0: [sdf] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov 27 01:10:50 localhost kernel: usb 5-1: reset full speed USB device using uhci_hcd and address 2
Nov 27 01:10:50 localhost kernel: pci 0000:01:00.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
Nov 27 01:10:50 localhost kernel: [drm:radeon_resume] *ERROR* 
Nov 27 01:10:50 localhost kernel: [drm] Loading R300 Microcode
Nov 27 01:10:50 localhost kernel: [drm] Num pipes: 1
Nov 27 01:10:50 localhost kernel: [drm] writeback test succeeded in 1 usecs
Comment 1 David Campbell 2008-11-27 18:46:46 EST
This problem is not apparent in f9 either, something new in f10.
Comment 2 Lev Shamardin 2008-12-02 17:18:17 EST
I can confirm the problem. The smolt profile is here: http://www.smolts.org/client/show/pub_d33f4595-a01e-49c9-9ba8-e363b8ffccfa

I've got these messages in logs:

Dec  2 12:25:35 lopeptoid kernel: Suspending console(s) (use no_console_suspend to debug)
Dec  2 12:25:35 lopeptoid kernel: [drm:drm_bo_evict_mm] *ERROR* lru empty
Dec  2 12:25:35 lopeptoid kernel: [drm] Num pipes: 1
...
Dec  2 12:25:35 lopeptoid kernel: pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Dec  2 12:25:35 lopeptoid kernel: [drm:radeon_resume] *ERROR* 
Dec  2 12:25:35 lopeptoid kernel: [drm] Loading R500 Microcode
Dec  2 12:25:35 lopeptoid kernel: [drm] Num pipes: 1
Dec  2 12:25:35 lopeptoid kernel: [drm] writeback test failed
Dec  2 12:25:35 lopeptoid kernel: [drm:drm_ttm_bind] *ERROR* Couldn't bind backend.
Dec  2 12:25:35 lopeptoid kernel: executing set pll
Dec  2 12:25:35 lopeptoid kernel: executing set crtc timing
Dec  2 12:25:35 lopeptoid kernel: [drm] LVDS-8: set mode 1280x800 10
Dec  2 12:25:35 lopeptoid kernel: executing set LVDS encoder
Dec  2 12:25:35 lopeptoid kernel: Restarting tasks ... done.

I've also found a workaround. I have disabled that fancy boot stuff, I mean "nomodeset" option to the kernel in /etc/grub.conf and suspend worked without problems already for 6 times.
Comment 3 Lev Shamardin 2008-12-02 17:19:45 EST
Some additional remarks:

1. I've discovered that the machine is not completely dead, it just pretends to be. At least if you have a second machine around you still can ssh to a semi-dead host and reboot it remotely.

2. Switching to radeonhd driver partially fixes the problem: machine gets back from suspend, but the picture on the screen is covered with dotty garbage. But it is still usable enough to make a clean reboot and may be even save some files before that. Switched back to radeon.
Comment 4 Lev Shamardin 2008-12-03 01:37:15 EST
*** Bug 473971 has been marked as a duplicate of this bug. ***
Comment 5 Lev Shamardin 2008-12-03 01:44:37 EST

*** This bug has been marked as a duplicate of bug 473195 ***
Comment 6 tmgrrd 2009-05-16 13:39:28 EDT
Created attachment 344285 [details]
nomodeset

Adding the 'nomodeset' to the end of my kernel line solved the problem.  All thanks and gratitude go to Lev Shamardin for fixing this for me.  I'd struggled with this issue for months, and was all but ready to revert back to Fedora 9 because of it.  Resume from sleep/hybernate works flawlessly for me now.

Note You need to log in before you can comment on or make changes to this bug.