Bug 473971 - Resume failure with ati driver (Thinkpad T60)
Resume failure with ati driver (Thinkpad T60)
Status: CLOSED DUPLICATE of bug 473340
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 12:01 EST by sdh4
Modified: 2018-04-11 11:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 01:37:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (1.73 KB, text/plain)
2008-12-01 12:01 EST, sdh4
no flags Details
Xorg logfile from a failed resume using the xorg.conf (81.94 KB, text/plain)
2008-12-01 12:02 EST, sdh4
no flags Details
Xorg logfile from a failed resume not using the xorg.conf (84.14 KB, text/plain)
2008-12-01 12:03 EST, sdh4
no flags Details
Video of failed resume / display corruption (2.57 MB, video/ogg)
2008-12-01 12:13 EST, sdh4
no flags Details

  None (edit)
Description sdh4 2008-12-01 12:01:39 EST
Created attachment 325259 [details]
xorg.conf file 

Description of problem:
Resume fails and the display shows continuously changing corruption
pm_trace gives: 
      hash matches drivers/base/power/main.c:387
      tty tty63: hash matches

Switching to the radeonhd driver gives similar corruption, but
the system resumes successfully, although anything on the screen is 
quickly corrupted.



Version-Release number of selected component (if applicable):
Lenovo Thinkpad T60
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]
xorg-x11-drv-ati-6.9.0-54.fc10.i386
Linux version 2.6.27.5-117.fc10.i686 (mockbuild@x86-7.fedora.phx.redhat.com) (gcc version 4.3.2 20081105 (Red Hat 4.3.2-7) (GCC) ) #1 SMP Tue Nov 18 12:19:59 EST 2008


How reproducible:
100%

Steps to Reproduce:
1. Boot
2. Log in
3. Suspend
4. Resume
  
Actual results:
Live corruption (fireworks display)

Expected results:
Resumed PC

Additional info:
Behaves similarly with/without xorg.conf. xorg.conf and X.org logs are attached
Comment 1 sdh4 2008-12-01 12:02:37 EST
Created attachment 325261 [details]
Xorg logfile from a failed resume using the xorg.conf
Comment 2 sdh4 2008-12-01 12:03:29 EST
Created attachment 325262 [details]
Xorg logfile from a failed resume not using the xorg.conf
Comment 3 sdh4 2008-12-01 12:13:11 EST
Created attachment 325266 [details]
Video of failed resume / display corruption
Comment 4 sdh4 2008-12-01 13:08:01 EST
The nomodeset kernel command line parameter seems to work around this problem, so it may actually be a kernel modesetting bug instead.
Comment 5 Jeff Gustafson 2008-12-02 15:53:11 EST
I have a Thinkpad T60p and my system will not suspend with the radeonhd driver.  The moon comes on but the system never truely suspends.  My system will suspend with the radeon driver, but will give me a blank screen when resumed.  I fixed the resume problem with the radeon driver by creating a file:

/etc/pm/config.d/chvt

Contents of the file as follows:

HOOK_BLACKLIST="90chvt"

After that, everything works just fine.  BTW, I am using the 64-bit distribution.  That may make a difference.  I was using f9 in i386 mode on the system and radeonhd worked just fine.
Comment 6 Matěj Cepl 2008-12-02 17:52:31 EST
(In reply to comment #5)
> I have a Thinkpad T60p and my system will not suspend with the radeonhd driver.

Jeff, I am sorry, but this wrong component (this is about standard ati drivers, not radeonhd, which doesn't have much common with ati/radeon) and we prefer one bug report per issue, so please file a new bug for your issue, and please do not forget to attach to it /var/log/Xorg.0.log and /etc/X11/xorg.conf you use.

Thank you.
Comment 7 Lev Shamardin 2008-12-03 01:37:15 EST
This seems to be the same problem.

*** This bug has been marked as a duplicate of bug 473340 ***
Comment 8 Jeff Gustafson 2008-12-03 04:45:26 EST
(In reply to comment #6)
> (In reply to comment #5)
> > I have a Thinkpad T60p and my system will not suspend with the radeonhd driver.
> 
> Jeff, I am sorry, but this wrong component (this is about standard ati drivers,
> not radeonhd, which doesn't have much common with ati/radeon) and we prefer one
> bug report per issue, so please file a new bug for your issue, and please do
> not forget to attach to it /var/log/Xorg.0.log and /etc/X11/xorg.conf you use.

My point really wasn't about the radeonhd driver, more of a suggestion about trying to blacklist various hooks to see if it helps at all.  I was also was having problems resuming with the ati driver.  No "fireworks" for me, just a blank screen.  Blacklisting the chvt hook has fixed the suspend/resume problem for me.  Maybe this is a hint for resolving the problem.

Note You need to log in before you can comment on or make changes to this bug.