Bug 47336 - esddsp not finding libesddsp.so shared library for some programs
esddsp not finding libesddsp.so shared library for some programs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: esound (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks: 479238
  Show dependency treegraph
 
Reported: 2001-07-04 16:19 EDT by Wesley Tanaka
Modified: 2009-03-05 11:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-08 05:12:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Tanaka 2001-07-04 16:19:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
When trying to run programs using esddsp, I receive error messages such as:

~ % esddsp mtv                                                   (altair)
13:11
mtvp: error while loading shared libraries: libesddsp.so: cannot open
shared object file: No such file or directory
mtvp_read_notification: error reading msg on fd 5: unknown error
[9302,0] mtv: mtv.c:6191: t=994277520.4419: fatal: cannot start player
(mtvp) - probably mtvp API version mismatch: unknown error (status=-1)

~ % esddsp vmware                                                (altair)
13:12
vmware: error while loading shared libraries: libesddsp.so: cannot open
shared object file: No such file or directory


How reproducible:
Always

Steps to Reproduce:
1. esddsp mtvp foo.mpg


Actual Results:  mtvp: error while loading shared libraries: libesddsp.so:
cannot open shared object file: No such file or directory


Expected Results:  mtvp should have opened

Additional info:

~ % rpm -q esound glibc                                          (altair)
13:21
esound-0.2.22-1
glibc-2.2.2-10


The bottom of my /usr/bin/esddsp file looks like this:

# setup esd to hijack calls made to /dev/dsp
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib

export LD_PRELOAD_PATH=${libdir}
export LD_PRELOAD='libesddsp.so libesd.so'

# invoke the program with the args given
exec "$@"
Comment 1 Elliot Lee 2001-12-28 14:24:13 EST
This was an old issue with some files being in esound-devel instead of esound -
has been fixed.

If 'rpm -qf /usr/lib/libesddsp.so' says the file belongs to esound-devel or to
no package at all, then that is indeed the problem and you need to upgrade.
Comment 2 Wesley Tanaka 2002-01-08 05:12:26 EST
/tmp % rpm -qf /usr/lib/libesddsp.so; esddsp mtv foo.mpg 
esound-0.2.22-5
mtvp: error while loading shared libraries: libesddsp.so: cannot open shared
object file: No such file or directory
mtvp_read_notification: error reading msg on fd 5: unknown error
[14277,0] mtv: mtv.c:6191: t=1010484890.3031: fatal: cannot start player (mtvp)
- probably mtvp API version mismatch: unknown error (status=-1)
Comment 3 Elliot Lee 2002-03-07 16:23:21 EST
I'm not going to leave this bug open and pretend I can do anything about it... I
did forget to ask (way) earlier if the file actually existed - if it doesn't,
just reinstall the esound package.

Also, if the esddsp command works fine with other programs (e.g. 'esddsp sox
/usr/share/sndconfig/sample.au -t ossdsp /dev/dsp'), then I would blame mtvp :)

Other than that, 'works for me' is the only response left.
Comment 4 John Morris 2004-07-12 19:51:52 EDT
Whatever the underlying issue is, it isn't a version problem.  the esd
in RHEL3 and VMware 2.x have the same problem.  Other apps like
Mozilla and xmms (manually reconfigured to use OSS) do work eith esddsp.

Note You need to log in before you can comment on or make changes to this bug.