Bug 473366 - Exiting X server while it is displaying causes a kernel panic
Exiting X server while it is displaying causes a kernel panic
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fpit (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 20:13 EST by Victor Bielawski
Modified: 2009-09-09 23:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 23:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (446.88 KB, text/plain)
2008-11-28 06:34 EST, Victor Bielawski
no flags Details
dmesg optput (66.95 KB, text/plain)
2008-11-28 06:36 EST, Victor Bielawski
no flags Details
xorg.conf from pastebin (1.21 KB, text/plain)
2008-11-30 19:06 EST, Peter Hutterer
no flags Details
Xorg log after crash (71.26 KB, text/plain)
2008-11-30 21:32 EST, Victor Bielawski
no flags Details
Xorg.1.log (29.71 KB, text/plain)
2008-12-05 18:52 EST, Victor Bielawski
no flags Details
dmesg (33.77 KB, text/plain)
2008-12-05 18:54 EST, Victor Bielawski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 19124 None None None Never

  None (edit)
Description Victor Bielawski 2008-11-27 20:13:39 EST
Version-Release number of selected component (if applicable):
> info xorg-x11-server-Xorg.i386
Installed Packages
Name       : xorg-x11-server-Xorg
Arch       : i386
Version    : 1.5.3
Release    : 5.fc10
> info xorg-x11-drv-fpit.i386
Installed Packages
Name       : xorg-x11-drv-fpit
Arch       : i386
Version    : 1.2.0
Release    : 1.fc9
> info kernel.i686
Installed Packages
Name       : kernel
Arch       : i686
Version    : 2.6.27.5
Release    : 117.fc10

How reproducible: Always

Steps to Reproduce:
1. Waste some money on a Gateway M285E, CX210, or similar.
2. Install Fedora and confirm that you can exit an X server.
3. Configure the FinePoint digitizer in xorg.conf like this: http://pastebin.mozilla.org/580199 (highlighted lines are the ones I added).
4. Restart X server.
5. Attempt to exit it, using either a "logoff" command or Ctrl Alt Backspace.
  
Actual results:
Weird screen with different-coloured lined on the sides and black in the middle shows; caps-lock light starts flashing at regular intervals. Machine is inaccessible from network.

Expected results:
X server closes and you are returned to either a console or display manager.

Additional info:
I have a Gateway M285E. I reused the home directory from a previous installation of Ubuntu.
Comment 1 Victor Bielawski 2008-11-27 20:39:50 EST
If I wasn't clear enough about this, there is no kernel panic if you happen to be using a different vt at the moment that the X server is closed.
Comment 2 Matěj Cepl 2008-11-28 03:09:52 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf), X server log file (/var/log/Xorg.*.log), and /var/log/dmesg to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Victor Bielawski 2008-11-28 06:34:54 EST
Created attachment 324982 [details]
Xorg.0.log
Comment 4 Victor Bielawski 2008-11-28 06:36:19 EST
Created attachment 324983 [details]
dmesg optput
Comment 5 Victor Bielawski 2008-11-28 06:37:25 EST
xorg.conf in comment #0 (the pastebin link)
Comment 6 Peter Hutterer 2008-11-30 19:06:48 EST
Created attachment 325161 [details]
xorg.conf from pastebin
Comment 7 Peter Hutterer 2008-11-30 19:09:16 EST
Is this the log file/dmesg from a crash? Or from the working setup?
Also, there's a lot of noise in the log file, suggesting that you suspended/resumed the server (or VT switched) a few times before obtaining the log. Please try to obtain a crash log from a "fresh" server to keep the log brief.
Comment 8 Victor Bielawski 2008-11-30 21:19:13 EST
Both of these were from a session using the failing configuration but which had not yet crashed.

I have no way of obtaining a dmesg from a crash. I will attach the Xorg log file as it exists immediately after a crash next time I restart.
Comment 9 Victor Bielawski 2008-11-30 21:32:02 EST
Created attachment 325165 [details]
Xorg log after crash

This is the log of an X server running GDM which I closed immediately after it loaded. I made a copy of the log in single user mode after restarting due to the kernel panic.
Comment 10 Peter Hutterer 2008-12-01 00:48:54 EST
How about this one: http://koji.fedoraproject.org/scratch/whot/task_965148/
Comment 11 Victor Bielawski 2008-12-01 06:59:49 EST
Should I also install the debuginfo package?
Comment 12 Peter Hutterer 2008-12-01 17:11:44 EST
that'd be a good idea, but may not be necessary. if it still crashes like above, we don't see a backtrace anyway so the debuginfo probably won't help.
Comment 13 Victor Bielawski 2008-12-01 17:56:56 EST
It still crashes and panics after installing the package.
Comment 14 Peter Hutterer 2008-12-01 19:09:37 EST
Next try: http://koji.fedoraproject.org/scratch/whot/task_968768/

Note that the panic is most likely a kernel fault, but maybe we can figure out what triggers the panic.
Comment 15 Victor Bielawski 2008-12-05 18:43:20 EST
The package doesn't help on Fedora 10.

I just installed Rawhide and the panic is gone, probably due to the Linux upgrade. The weird line pattern is still there and you can't change vts using CtrlAltF[1-6]. However, new X servers can be started by logging in using SSH to bring the machine back to a mostly usable state. 

Should this bug be morphed?
Comment 16 Victor Bielawski 2008-12-05 18:52:45 EST
Created attachment 325942 [details]
Xorg.1.log

This is the Xorg.1.log after a crash under Rawhide.
Comment 17 Victor Bielawski 2008-12-05 18:54:31 EST
Created attachment 325943 [details]
dmesg

dmesg from after a crash under Rawhide.
Comment 18 Victor Bielawski 2008-12-05 18:56:05 EST
I just discovered that running "chvt 1" via SSH also works.
Comment 19 Peter Hutterer 2008-12-07 20:15:51 EST
(In reply to comment #15)
> The package doesn't help on Fedora 10.

weird. I removed all the code from the driver during unloading so anything after the UnloadModule message is a noop. And the unload is the last message we see in the log.
Just to make sure - if you remove the fpit driver from the xorg.conf, you don't see any of these issues?
Comment 20 Victor Bielawski 2008-12-07 20:28:35 EST
I don't see these issues if I remove the fpit driver from xorg.conf.
Comment 21 Peter Hutterer 2008-12-16 22:20:34 EST
Filed upstream as bug 19124.
http://bugs.freedesktop.org/show_bug.cgi?id=19124

However, I have to warn you that fpit is unmaintained and your best chances are to look at the source and try to narrow down the cause of the crash yourself.
The git source directory is available from git://anongit.freedesktop.org/git/xorg/driver/xf86-input-fpit.
Comment 22 Fedora Update System 2009-08-27 18:40:05 EDT
xorg-x11-drv-fpit-1.3.0-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xorg-x11-drv-fpit-1.3.0-3.fc11
Comment 23 Fedora Update System 2009-08-27 18:53:52 EDT
xorg-x11-drv-fpit-1.2.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-fpit-1.2.0-2.fc10
Comment 24 Peter Hutterer 2009-08-27 18:54:56 EDT
Victor: please try either of the packages above (depending on which release you're on) and let me know if that's fixed for you now.
You're the only fpit user I know of, so I do rely on you for testing.
Comment 25 Fedora Update System 2009-08-28 17:59:30 EDT
xorg-x11-drv-fpit-1.3.0-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-fpit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9097
Comment 26 Fedora Update System 2009-08-28 18:00:17 EDT
xorg-x11-drv-fpit-1.2.0-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-fpit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9106
Comment 27 Fedora Update System 2009-09-09 23:42:52 EDT
xorg-x11-drv-fpit-1.2.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2009-09-09 23:49:50 EDT
xorg-x11-drv-fpit-1.3.0-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.