Bug 473380 - Installer crash over "/mnt/swap" mount point when upgrading
Installer crash over "/mnt/swap" mount point when upgrading
Status: CLOSED DUPLICATE of bug 473260
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 02:01 EST by H.Janssen
Modified: 2008-12-03 14:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 14:27:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile from DVD install (11.04 KB, application/octet-stream)
2008-12-03 14:09 EST, H.Janssen
no flags Details
Crash dump (159.21 KB, text/plain)
2008-12-03 14:10 EST, H.Janssen
no flags Details
fstab triggering the crash (516 bytes, text/plain)
2008-12-03 14:11 EST, H.Janssen
no flags Details

  None (edit)
Description H.Janssen 2008-11-28 02:01:36 EST
Description of problem:

Fedora8 + WinXP dual boot system. 1Gbyte FAT32 partition for the Windows
swap file. Fedora is running without swap, when needed I use the windows
swap file for Linux with
"mkswap pagefile.sys,swapon pagefile.sys",
that's why the FAT32 partition was mounted as:

/dev/sda3              /mnt/swap              auto    defaults        0 0


Upon upgrade of Fedora 8 to 10 on /dev/sda2 to Fedora 10, the installer
crashes over this "/mnt/swap" just after selecting the system to be 
upgraded and pressing "next"


Version-Release number of selected component (if applicable):

Fedora release 10 (Cambridge)

How reproducible:
Perfect

Steps to Reproduce:
1. Create the mount point above, start Fedora 10 upgrade from DVD
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2008-12-02 11:18:47 EST
Please attach the complete traceback to this bug report so we can see what's going on and can try to fix it.
Comment 2 H.Janssen 2008-12-03 14:09:47 EST
Created attachment 325579 [details]
Logfile from DVD install

Copied fstab.anaconda to fstab
Fortunately, upgrade from Fedora 10 to Fedora 10 was possible too :)
Comment 3 H.Janssen 2008-12-03 14:10:22 EST
Created attachment 325580 [details]
Crash dump
Comment 4 H.Janssen 2008-12-03 14:11:01 EST
Created attachment 325581 [details]
fstab triggering the crash
Comment 5 Chris Lumens 2008-12-03 14:27:30 EST

*** This bug has been marked as a duplicate of bug 473260 ***

Note You need to log in before you can comment on or make changes to this bug.