Bug 473260 - F9 to F10 DVD Upgrade
F9 to F10 DVD Upgrade
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsUpdatesImg anaconda_trace_hash:b...
:
: 473170 473380 473467 473529 474711 478829 492534 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 07:58 EST by Alexey Kuznetsov
Modified: 2009-03-27 14:26 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 13:39:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (90.84 KB, text/plain)
2008-11-27 07:58 EST, Alexey Kuznetsov
no flags Details
Attached traceback automatically from anaconda. (144.31 KB, text/plain)
2008-11-27 08:08 EST, Alexey Kuznetsov
no flags Details
Attached traceback automatically from anaconda. (109.84 KB, text/plain)
2008-12-10 09:40 EST, Andy Ward
no flags Details
Attached traceback automatically from anaconda. (138.24 KB, text/plain)
2008-12-18 06:16 EST, Varun
no flags Details
Attached traceback automatically from anaconda. (142.86 KB, text/plain)
2009-02-14 14:38 EST, brett.c.stewart
no flags Details

  None (edit)
Description Alexey Kuznetsov 2008-11-27 07:58:29 EST
This bug was filed automatically by anaconda.
Comment 1 Alexey Kuznetsov 2008-11-27 07:58:38 EST
Created attachment 324873 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexey Kuznetsov 2008-11-27 08:08:52 EST
Created attachment 324876 [details]
Attached traceback automatically from anaconda.
Comment 3 Alexey Kuznetsov 2008-11-27 08:12:59 EST
second crash for my PPC machine, another installation. In some reazon (probably another bug in anaconda) anaconda put this bug as attachment for current bug report.
Comment 4 Matěj Cepl 2008-11-28 13:34:14 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 5 Alexey Kuznetsov 2008-11-28 17:04:11 EST
Dump in comment #2 is fake (i tried to upgrade f10 to f10). I had two upgrade attempts. First attemp enged with exception simillar to comment 2, but upgrade procedure not stopped. Probably it depend on another bug in save exception dialog.

In this case i tried to save exception to bugzilla but i typed wrong user name, unexist. (user name 'axet' instead 'ak@axet.ru' with my real password). after it i got no errors or warning dialog. after it i close exeption dialog by esc key or close window button. And upgrade procedure continued...

After upgrade procedure i tried to reproduce bug on my ppc machine, and here is comment #2.
Comment 6 John E. Harbold 2008-11-29 23:51:49 EST
I too had this same anaconda crash when I tried to do a F9 -> F10 upgrade.  The other problem is I can't save the stack dump.  I did copy it by hand.  The python stack dump is identical to mine.

My system is:

Pentium II 450 MHz
327600 MB

Is there any other information needed?
Comment 7 Chris Lumens 2008-12-02 13:24:00 EST
*** Bug 473170 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2008-12-02 13:24:11 EST
*** Bug 473467 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2008-12-02 15:20:47 EST
When you hit the traceback, can you press ctrl-alt-f2 to get to a shell, type mount, and paste the output into this bug report?  Right now, I'm not seeing how it's possible to get into the situation you're in and need a little more information.
Comment 10 Chris Lumens 2008-12-02 15:43:24 EST
*** Bug 473529 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2008-12-02 15:44:08 EST
Matt - are you able to reproduce this on a machine that I can come sit in front of?
Comment 12 Chris Lumens 2008-12-03 14:27:30 EST
*** Bug 473380 has been marked as a duplicate of this bug. ***
Comment 13 Alexey Kuznetsov 2008-12-04 04:12:03 EST
(In reply to comment #9)
> When you hit the traceback, can you press ctrl-alt-f2 to get to a shell, type
> mount, and paste the output into this bug report?  Right now, I'm not seeing
> how it's possible to get into the situation you're in and need a little more
> information.

fdisk -l


Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc0a5aeec

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       14593   117218241   83  Linux


mount


rootfs on / type rootfs (rw)
/proc on /proc type proc (rw)
/dev on /dev type tmpfs (rw)
/dev/pts on /dev/pts type devpts (rw,mode=600)
/sys on /sys type sysfs (rw)
none on /tmp type ramfs (rw)
/dev/sr0 on /mnt/stage2 type iso9660 (ro)
/dev/loop0 on /mnt/runtime type squashfs (ro)
/selinux on /selinux type selinuxfs (rw)
/dev/sda1 on /mnt/sysimage type ext3 (rw,errors=continue,user_xattr,acl,data=ordered)
/dev/sdb1 on /1 type ext4 (rw,barrier=1,data=ordered)
Comment 14 Alexey Kuznetsov 2008-12-04 04:13:07 EST
/dev/sdb1 on /1 type ext4 (rw,barrier=1,data=ordered)

is my usb-flash, connected after traceback for log's transfer
Comment 15 Alexey Kuznetsov 2008-12-04 08:22:30 EST
i found that really happens. problem with swap file

my system have swap file in root file system. look like anaconda enable swap file which prevent to unmount old file system!

[axet@axet-laptop ~]$ cat /etc/fstab
UUID=17050de4-c9bc-4938-9615-090c227ce8fb /                       ext3    defaults        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/var/swap		swap			swap
Comment 16 Neal Becker 2008-12-04 09:35:31 EST
Yes, I also have a swap file in root fs.  I recall (vaguely) that I noticed anaconda had enabled it, and thought that was strange, but didn't realize it was the problem.
Comment 17 Alexey Kuznetsov 2008-12-04 09:41:18 EST
remove "/var/swap  swap   swap" line from fstab and you get able to upgrade!
Comment 18 Will Woods 2008-12-05 13:53:56 EST
*** Bug 474711 has been marked as a duplicate of this bug. ***
Comment 19 Will Woods 2008-12-05 14:04:27 EST
John, do you also have a swap file configured?
Comment 20 alauschke 2008-12-05 14:29:01 EST
I confirm that deleting the swap file line in /etc/fstab allowed me to boot into F10. I had originally filed 474711, which is now closed duplicate.
Comment 21 Will Woods 2008-12-05 16:51:32 EST
I can reproduce this pretty easily by creating a swap file:
  dd if=/dev/zero of=/var/swap bs=1M count=2048
  mkswap /var/swap
  echo '/var/swap swap swap defaults 0 0' >> /etc/fstab
  swapon -a
and then attempting an upgrade. Removing the swapfile from fstab fixes it.
Comment 22 Chris Lumens 2008-12-05 18:00:34 EST
Patch to fix this up for discussion in the following thread:

https://www.redhat.com/archives/anaconda-devel-list/2008-December/msg00104.html
Comment 23 John E. Harbold 2008-12-07 17:21:01 EST
Yes, I do have two swap files configured and I did commented them out in /etc/fstab.  I was able to get further, but the update process hung.  I saw a Bugzilla entry dealing with the update process hang.
Comment 24 Chris Lumens 2008-12-08 11:48:12 EST
I've pushed a fix for this that will be included in the next build of anaconda. In addition, we're considering this fix for inclusion in an updates.img against F10 to help people complete their upgrades.
Comment 25 Andy Ward 2008-12-10 09:40:20 EST
Created attachment 326511 [details]
Attached traceback automatically from anaconda.
Comment 26 Varun 2008-12-18 06:16:58 EST
Created attachment 327313 [details]
Attached traceback automatically from anaconda.
Comment 27 Chris Lumens 2009-01-05 11:03:59 EST
*** Bug 478829 has been marked as a duplicate of this bug. ***
Comment 28 John E. Harbold 2009-01-19 17:38:24 EST
It has been a while since Chris Lumens posted comment #24 (over a month) and there has been three subsequent comments since.  Has there been any movement on this bug?  It seems to still have the status of ON_QA.  It there a significant backlog of higher priority bugs ahead of this one?  I would really like to start upgrading to F10 and use it before F11 gets released.
Comment 29 Jason Potkanski 2009-02-12 13:07:57 EST
My trace posted to Bug 478829 . Removing swap from fstab resolved the issue.
Comment 30 Alexey Kuznetsov 2009-02-12 13:13:47 EST
why this bug still not closed?
Comment 31 Chris Lumens 2009-02-12 13:39:11 EST
I was waiting for some official work on getting an updates image together, but that never materialized.  Therefore, I've put together my own updates image for this bug.  If you add

updates=http://clumens.fedorapeople.org/f10-updates.img

to your boot arguments, you should be able to work around this problem.  If you do not have network access, you can still use an updates image on physical media.  For more information on working with an updates image, see http://fedoraproject.org/wiki/Anaconda/Updates.  Thanks for your patience.
Comment 32 brett.c.stewart 2009-02-14 14:38:21 EST
Created attachment 331934 [details]
Attached traceback automatically from anaconda.
Comment 33 John E. Harbold 2009-02-21 13:45:30 EST
I'd like to thank Chris Lumens for his effort in fixing this bug.  I was afraid I was going to evolve into Homo Sapien Sapiens Paleo Flatus.
My question is, has the net install CD, Fedora-10-i386-netinstall.iso, been re-spun with the Mr. Lumens updates?  If it hasn't, then, I could do this.  My next question is, where would I upload this ISO image?
Comment 34 Chris Lumens 2009-03-27 10:05:30 EDT
*** Bug 492534 has been marked as a duplicate of this bug. ***
Comment 35 jason32 2009-03-27 14:26:37 EDT
Hello,

thank you for your fast replay.

However, I'd like to solve the issue by being able to use pregrade to do an upgrade from f9 to f10.

How exactly do I do this?

Thank you

Jason

Note You need to log in before you can comment on or make changes to this bug.