Bug 473420 - snmpd is crashing on start
snmpd is crashing on start
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 474144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 07:58 EST by Max Krasilnikov
Modified: 2008-12-06 23:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 23:12:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Krasilnikov 2008-11-28 07:58:50 EST
Description of problem:

when starting snmpd it is crashing with segfault.

Version-Release number of selected component (if applicable):

net-snmp-5.4.2.1-1.fc10.x86_64
net-snmp-libs-5.4.2.1-1.fc10.x86_64

How reproducible:

start snmpd.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: In attachement - strace /usr/sbin/snmpd -f > strace.log 2>&1
Comment 1 Göran Uddeborg 2008-11-28 18:33:14 EST
This happens to me too.  I spent some time debugging, and I'm pretty convinced it is an upstreams bug in the inclusion of RPM header files:

https://sourceforge.net/tracker/index.php?func=detail&aid=2357163&group_id=12694&atid=112694

Assuming you hit the same problem as I do, a workaround is to add "-I -hr_swinst" to the options in /etc/sysconfig/snmpd
Comment 2 Anthony Messina 2008-11-29 11:08:06 EST
I can confirm the issue. I tried to catch it here: https://admin.fedoraproject.org/updates/F10/FEDORA-2008-10451 but it got puched just after I entered that comment.
Comment 3 Jan Safranek 2008-12-01 04:55:11 EST
It's fallout of new rpm-4.6. I didn't notice getRpmPath() moved to rpmfileutil.h. The compiler does not find it -> it assumes 'int' is returned -> something very bad happens on x86_64.

Panu, could you add #include<rpmfileutil.h> to rpmmacros.h?
Comment 4 Jindrich Novy 2008-12-01 06:17:34 EST
Comitted to upstream.

Will be backported soon in F10 and rawhide.
Comment 5 Jan Safranek 2008-12-02 09:01:10 EST
*** Bug 474144 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2008-12-02 09:29:59 EST
rpm-4.6.0-0.rc1.8 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpm-4.6.0-0.rc1.8
Comment 7 Major Hayden 2008-12-03 20:41:08 EST
Would it be possible to have net-snmp rebuilt against rpm-4.6.0-0.rc1.8 and pushed out?

https://admin.fedoraproject.org/updates/rpm-4.6.0-0.rc1.8
Comment 8 Jan Safranek 2008-12-04 03:54:11 EST
The fixed rpm got to the koji buildroot this night, I'm compiling net-snmp right now. There are processes around and it takes some time to release fixed rpms.
Comment 9 Fedora Update System 2008-12-04 04:10:01 EST
net-snmp-5.4.2.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/net-snmp-5.4.2.1-2.fc10
Comment 10 Fedora Update System 2008-12-06 23:12:21 EST
net-snmp-5.4.2.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-12-06 23:24:31 EST
rpm-4.6.0-0.rc1.8 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.