This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 474144 - snmpd crashes on startup
snmpd crashes on startup
Status: CLOSED DUPLICATE of bug 473420
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 08:55 EST by Tom Hughes
Modified: 2008-12-02 09:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 09:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2008-12-02 08:55:08 EST
Description of problem:

snmpd crashes on startup

Version-Release number of selected component (if applicable):

net-snmp-5.4.2.1-1.fc10.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Start snmpd
2. Watch it crash
  
Actual results:

snmpd crashes

Expected results:

snmpd runs and answers snmpd queries

Additional info:

Backtrace for crash:

#0  strlen () at ../sysdeps/x86_64/strlen.S:48
#1  0x0000000002cbd5ee in _IO_vfprintf_internal (s=0x7fffffffc580, 
    format=<value optimized out>, ap=0x7fffffffc6f0) at vfprintf.c:1581
#2  0x0000000002d708f8 in ___vsnprintf_chk (s=0x7fffffffc860 "", 
    maxlen=<value optimized out>, flags=1, slen=<value optimized out>, 
    format=0x88dba2 "%s/Packages", args=0x7fffffffc6f0) at vsnprintf_chk.c:65
#3  0x0000000002d7083b in ___snprintf_chk (
    s=0xfffffffff829c940 <Address 0xfffffffff829c940 out of bounds>, 
    maxlen=8969122, flags=-14536, slen=0, 
    format=0xfefefefefefefeff <Address 0xfefefefefefefeff out of bounds>)
    at snprintf_chk.c:36
#4  0x00000000007da4f2 in snprintf () at /usr/include/bits/stdio2.h:65
#5  init_hr_swinst () at host/hr_swinst.c:217
#6  0x000000000088b5d5 in init_mib_modules ()
    at ../agent/mibgroup/mib_module_inits.h:17
#7  0x00007ffff7ffc8ee in main (argc=7, argv=0x7fffffffdc28) at snmpd.c:920
Comment 1 Jan Safranek 2008-12-02 09:01:10 EST
I know, I know... Sorry for inconvenience :(

*** This bug has been marked as a duplicate of bug 473420 ***

Note You need to log in before you can comment on or make changes to this bug.