Bug 473467 - Anaconda too aggressive when acquiring swap
Anaconda too aggressive when acquiring swap
Status: CLOSED DUPLICATE of bug 473260
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-11-28 12:29 EST by Anduin Withers
Modified: 2008-12-02 13:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-02 13:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anduin Withers 2008-11-28 12:29:13 EST
Description of problem:

During an upgrade from F9 to F10, ananconda crashes when trying to unmount (at the point immediately after selecting to upgrade rather than reinstall). The cause in this case was the use of a swap file in /.

Version-Release number of selected component (if applicable):

F10 anaconda.

How reproducible:


Steps to Reproduce:

On a pre-F10 system:
1. dd if=/dev/zero of=/SWAP bs=1M count=200
2. mkswap /SWAP
3. echo "/SWAP swap swap defaults 0 0" >> /etc/fstab
4. Now try to upgrade
Actual results:

Installer crash.

Expected results:

Don't use the swap found if it is on a fs that will be unmounted, or remove it/add it back after remounted.

Additional info:

anaconda exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/isys.py", line 374, in umount
    rc = _isys.umount(what)
  File "/usr/lib/anaconda/fsset.py", line 195, in umount
    isys.umount(path, removeDir = 0)
  File "/usr/lib/anaconda/fsset.py", line 2165, in umount
  File "/usr/lib/anaconda/fsset.py", line 2109, in umountFilesystems
  File "/usr/lib/anaconda/fsset.py", line 1914, in migrateFilesystems
    self.umountFilesystems(anaconda.rootPath, swapoff = False)
  File "/usr/lib/anaconda/packages.py", line 98, in doMigrateFilesystems
    anaconda.id.fsset.migrateFilesystems (anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
  File "/usr/lib/anaconda/text.py", line 741, in run
  File "/usr/bin/anaconda", line 955, in <module>
SystemError: (16, 'Device or resource busy')
Comment 1 Chris Lumens 2008-12-02 13:24:11 EST

*** This bug has been marked as a duplicate of bug 473260 ***

Note You need to log in before you can comment on or make changes to this bug.