This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 473529 - anaconda upgrade fails if swap is a file in /etc/fstab
anaconda upgrade fails if swap is a file in /etc/fstab
Status: CLOSED DUPLICATE of bug 473260
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 23:20 EST by Matt Domsch
Modified: 2008-12-02 15:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 15:43:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-11-28 23:20:18 EST
Description of problem:
Anaconda tracebacks fairly early in the upgrade process (started via preupgrade) if the system's /mnt/sysimage/etc/fstab file contains a swap file (not swap partition).  Fails in migrateFilesystems trying to umount /mnt/sysimage and tracebacks.

On my system, I have a swap file /swap.1  instead of a swap partition.  This is listed in /etc/fstab.

Removing that line from /etc/fstab and restarting the anaconda upgrade succeeds.

Version-Release number of selected component (if applicable):
Fedora 10

How reproducible:
always

Steps to Reproduce:
1. have a swap file listed in /etc/fstab
2. preupgrade from F9 to F10
 
Actual results:
traceback and failure

Expected results:
success
Comment 1 Chris Lumens 2008-12-02 10:43:04 EST
Can you attach your /etc/fstab to this bug report?
Comment 2 Matt Domsch 2008-12-02 10:52:23 EST
This was the failure-inducing fstab.

/dev/md1                /                       ext3    defaults        1 1
/dev/md0                /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/swap.1                 none                    swap    defaults        0 0
Comment 3 Chris Lumens 2008-12-02 12:51:40 EST
Oh, I forgot to ask for the traceback too, if you still have it available.
Comment 4 Matt Domsch 2008-12-02 13:06:36 EST
Unfortunately, anaconda at that point won't let me save it.  pdb is available, but saving causes an immediate crash.
Comment 5 Chris Lumens 2008-12-02 15:43:24 EST

*** This bug has been marked as a duplicate of bug 473260 ***

Note You need to log in before you can comment on or make changes to this bug.