Bug 473551 - Fix dejavu-* dependencies
Summary: Fix dejavu-* dependencies
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rrdtool
Version: rawhide
Hardware: All
OS: Linux
urgent
high
Target Milestone: ---
Assignee: Chris Ricker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 473550 (view as bug list)
Depends On:
Blocks: F11Target
TreeView+ depends on / blocked
 
Reported: 2008-11-29 11:00 UTC by Nicolas Mailhot
Modified: 2009-05-26 16:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-26 16:02:32 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2008-11-29 11:00:47 UTC
The dejavu-fonts and dejavu-lgc-fonts packages are gone in Fedora 11.
Please change your package deps to one or several of:

	dejavu-fonts-sans
	dejavu-fonts-sans-mono
	dejavu-fonts-serif
	dejavu-fonts-lgc-sans
	dejavu-fonts-lgc-sans-mono
	dejavu-fonts-lgc-serif


http://koji.fedoraproject.org/koji/buildinfo?buildID=68927

The compat packages are transitory and will be gone in F12

Comment 1 Nicolas Mailhot 2008-11-29 11:11:38 UTC
*** Bug 473550 has been marked as a duplicate of this bug. ***

Comment 2 Alan Pevec 2008-11-30 12:01:19 UTC
compat packages don't help, packages depending on rrdtools don't build:
https://koji.fedoraproject.org/koji/getfile?taskID=963810&name=root.log

> Error: Missing Dependency: dejavu-lgc-fonts is needed by package rrdtool

Comment 3 Nicolas Mailhot 2008-11-30 13:33:29 UTC
Maybe I was not clear enough? Do *NOT* try to depend on the compat packages. They're not here long term. Use the others

Comment 4 Alan Pevec 2008-11-30 13:55:00 UTC
Your message is clear, but mine wasn't: I wanted to say that it's _urgent_ to fix rrdtool - it's basically broken in rawhide now.

Comment 5 Kostas Georgiou 2008-12-01 13:40:56 UTC
This stops ganglia being rebuild for dist-f11-python so it would be nice if it can fixed soon.

Comment 6 Jarod Wilson 2008-12-01 15:09:22 UTC
Commits are open to anyone in the provenpackager group... Anywho, modified build underway now...

Comment 7 Iain Arnell 2009-05-24 12:16:52 UTC
I guess that Nicolas' message really wasn't clear enough after all.  The -compat packages have indeed gone now and once again, rrdtool is broken. As before, this is breaking builds in rawhide for anything depending on rrdtool.

DEBUG util.py:256:  rrdtool-1.3.8-1.fc12.ppc from build has depsolving problems
DEBUG util.py:256:    --> Missing Dependency: dejavu-fonts-lgc-compat is needed by package rrdtool-1.3.8-1.fc12.ppc (build)
DEBUG util.py:256:  Error: Missing Dependency: dejavu-fonts-lgc-compat is needed by package rrdtool-1.3.8-1.fc12.ppc (build)

Comment 8 Jarod Wilson 2009-05-26 16:02:32 UTC
Fixed yet again for the font package name dependency of the week. rrdtool-1.3.8-2 should get spit out of the build system shortly.


Note You need to log in before you can comment on or make changes to this bug.