Bug 473667 - netinst will not accept static network card data
netinst will not accept static network card data
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 15:41 EST by Ray Todd Stevens
Modified: 2013-01-09 23:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 21:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-11-29 15:41:46 EST
Description of problem:

When running from the netins ios immage I can't get the systme to accept my ip address information.

Version-Release number of selected component (if applicable):


How reproducible:

Have yet to get it to work.   Running the disk1 ios and then using askmethod seems to still work.

Steps to Reproduce:
1.make a netinst cd
2.boot from it
3.get to the point of entering network information

enter 

address a.b.c.b (a public ip) /255.255.255.224
gateway a.b.c.1 (first ip in network is thew router)
name server 10.10.1.1  (we have an internal network off the router that has our main name server)
  
Actual results:

you get a nondescript error message when you click to go on.
ctrlalt f5 screen has some more logical messages.   The talk about being unable to parse ifcfg-eth0.new.   When I check I can't find such a file, but can find an ifcfg-eth0 which contains logical values which result from the data entered.



Expected results:

going on and asking for a url and then installing

Additional info:
Comment 1 Ray Todd Stevens 2008-12-15 16:05:10 EST
I wonder if this has anything to do with Bug 469434?
Comment 2 David Cantrell 2008-12-18 00:09:17 EST
I cannot reproduce this bug locally using rawhide.
Comment 3 Ray Todd Stevens 2008-12-18 14:37:26 EST
OK maybe it got fixed at some point.   But lets make sure we are talking the same thing.

Are you booting from a cd made from the netinst iso?

You said that you used the rawhide one. The one I used was in 10 and was apparently generated on 11/20.   I can't find any newer ones???
Comment 4 David Cantrell 2008-12-18 14:44:46 EST
(In reply to comment #3)
> OK maybe it got fixed at some point.   But lets make sure we are talking the
> same thing.
> 
> Are you booting from a cd made from the netinst iso?

Yes.

> You said that you used the rawhide one. The one I used was in 10 and was
> apparently generated on 11/20.   I can't find any newer ones???

http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/images/
Comment 5 Ray Todd Stevens 2008-12-18 16:46:03 EST
Interesting I can't find a netinst iso at that url.   There is a boot.iso  The problem I was experiencing as specific to the disk generated for the netinst.iso image.

Using the first disk or I believe probably the "boot" disk worked.   This disk in the current release seems to work.   It was how I completed successfully.  Instead of using the netinst I used the first cd in the cd set.   I exited out added askmethod and then returned and booted.   Then I selected to install from url and everything ran hunky doory.   But using the netinst disk did not work.  It seems to be a error in this specific image.
Comment 6 David Cantrell 2008-12-18 17:41:58 EST
In rawhide, we are only providing a boot.iso image, which is the installer images on a bootable CD.  There are no packages on the CD, so you have to perform a network install to complete the installation.

Where did you get the netinst image you used initially?
Comment 8 David Cantrell 2008-12-18 18:21:46 EST
Going to reassign this one to pungi (which may be wrong, but it should pass in front of jkeating).

jkeating,

Why would boot.iso and the netinst iso be different?
Comment 9 Jesse Keating 2008-12-18 18:53:17 EST
They aren't.  On the filesystem, netinst.iso is a hardlink back to boot.iso.  boot.iso is unchanged in name for compat and historical reasons, but the iso we expose in isos/ has been renamed to better extol it's functionality.

It's hard to say what happened here without a bit more information, as it seems Ray is testing various isos from the Fedora 10 release, and David is testing isos from post-F10 rawhide.  The isos tested (netinst.iso from 10 and boot.iso from rawhide) are essentially the same, but will of course vary due to one being of 10 content, one being of post-10 content.

Since the bug is filed against 10, I'm kicking it back to anaconda (which could rightfully do a CLOSED->RAWHIDE)
Comment 10 David Cantrell 2008-12-18 21:21:56 EST
Noted.  Thanks, Jesse.  Since I can't reproduce this one in rawhide, I'm closing it.
Comment 11 Ray Todd Stevens 2008-12-28 14:01:55 EST
interesting.   Now when I use this disk (iso generated from file created 12/27) it doesn't even bother to ask me for a network interface information or apparently try to bring it up.   It also errors out and will not allow me to do anything with the error data.

Note You need to log in before you can comment on or make changes to this bug.