Bug 473692 - prepareupgrade failed on fedora 9
prepareupgrade failed on fedora 9
Status: CLOSED DUPLICATE of bug 473782
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 20:23 EST by Russell Miller
Modified: 2014-01-21 18:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 13:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Miller 2008-11-29 20:23:44 EST
Description of problem:

I tried to upgrade to fedora 10.  preupgrade appeared to work, but it didn't set up grub properly.  When I rebooted, it was missing "/var" off of the location ("/cache/...").  Didn't work.  Fixing the grub entry and rebooting fixed it.

Certainly not something that would have been easy for a n00b.  Might wanna take a look at that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Guthrie 2008-12-02 14:53:44 EST
Both of my f9 -> f10 upgrades have ended up with corrupted GRUB MBRs after the upgrade.  One of them would print out "GRUB", and then reboot.  The other just repeatedly printed out "GRUB" across the screen.  I was able to fix both of them by using a rescue disk and re-installing the grub MBR from the grub command-line shell.  Not much of a problem, but kind of annoying.

Let me know if you need any more information.
Comment 2 John Guthrie 2008-12-02 15:17:37 EST
I should add that for both of these upgrades, the installation was done from a URL.  The downloaded ISO that I used for the data under that URL did pass the SHA1 checksum.
Comment 3 Will Woods 2008-12-05 13:31:43 EST
The missing /var is bug 473782. There will be a workaround for that in the next build of preupgrade.

The GRUB bug is an unrelated (but unfortunate) side-effect of GRUB upgrades on some systems. It's really hard for us to reproduce so we haven't been able to fix it yet. It's been around since F9 - maybe F8. It's been filed many times - bug 450143 is a recent example.

Glad you got your systems working despite these problems, though!

*** This bug has been marked as a duplicate of bug 473782 ***

Note You need to log in before you can comment on or make changes to this bug.