Bug 473782 - upgrading process is trying to locate repository in /mnt/sysimage/cache/preupgrade (notice missing /var)
upgrading process is trying to locate repository in /mnt/sysimage/cache/preup...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 473692 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 10:40 EST by Matěj Cepl
Modified: 2014-01-21 18:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:08:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-11-30 10:40:56 EST
Description of problem:
not much more to say now, than what's in summary -- I have created in VT2 symlink from /mnt/sysimage/var/cache/preupgrade to /mnt/sysimage/cache/preupgrade and upgrade currently continues 

Version-Release number of selected component (if applicable):
preupgrade-1.0.0-1.fc8

How reproducible:
happened once (but once is enough ;-))

Steps to Reproduce:
1.just run preupgrade and follow its instructions
2.
3.
  
Actual results:
upgrade halts saying that it cannot find preupgrade repository repomd.xml

Expected results:
should just work
Comment 1 Will Woods 2008-12-05 13:27:56 EST
There's a bug in anaconda that makes it fail to find /var properly, if you have it on separate partition. 

The problem is that anaconda notices that /var is already mounted, and doesn't bother re-mounting it - but it doesn't pay attention to *where* it's mounted, so it checks for the given path (/cache/yum/preupgrade) under your root filesystem rather than under /var.

Your workaround is OK, or you can also change the boot commandline so the repo=XXX parameter says:
  repo=hd::/var/cache/yum/preupgrade

This may be a bug in anaconda.. or it might be construed as a feature. Either way, a workaround will be in the next build of preupgrade.
Comment 2 Will Woods 2008-12-05 13:31:43 EST
*** Bug 473692 has been marked as a duplicate of this bug. ***
Comment 3 Will Woods 2008-12-15 17:35:59 EST
preupgrade-1.0.1 built, should be in updates-testing soon.
Comment 4 Fedora Update System 2008-12-16 17:35:38 EST
preupgrade-1.0.1-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc8
Comment 5 Fedora Update System 2008-12-16 17:38:20 EST
preupgrade-1.0.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc9
Comment 6 Fedora Update System 2008-12-16 17:38:36 EST
preupgrade-1.0.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc10
Comment 7 Fedora Update System 2008-12-21 03:22:55 EST
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-11587
Comment 8 Fedora Update System 2008-12-21 03:38:00 EST
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11540
Comment 9 Fedora Update System 2008-12-21 03:45:38 EST
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11437
Comment 10 Fedora Update System 2009-01-07 04:07:37 EST
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-01-07 04:08:05 EST
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-01-07 04:24:08 EST
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.