Bug 473695 - snd-intel8x0: Pops and clicks listening to audio in F10
snd-intel8x0: Pops and clicks listening to audio in F10
Status: CLOSED DUPLICATE of bug 471804
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-29 21:22 EST by Casey Dahlin
Modified: 2014-06-18 04:46 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 09:12:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casey Dahlin 2008-11-29 21:22:26 EST
I've been getting little pops and clicks listening to audio since upgrading to f10 (pulseaudio-0.9.3-6.fc10). Its very prominent in Rhythmbox, and on Youtube videos the glitches are far more infrequent but still present.
Comment 1 Michael Schwendt 2008-12-03 09:45:34 EST
Only "little pops and clicks"? Consider yourself lucky.
Here Rhythmbox and Audacious (bug 466350) suffer from interruptions.
Comment 2 Kurt Bechstein 2008-12-03 11:49:54 EST
Having same problem when using Rhythmbox and pretty much any audio app.  Solved problem by removing pulseaudio from system and just using alsa since it was very annoying.  However, obviously this is not the ideal solution.  Seen lots of other reports  online about this and others commenting that the same pulseaudio subsystem works on the same hardware using another distro but not with f10 so it definitely sounds like a pulseaudio issue in f10.  Let me know if I can help this one out any more.
Comment 3 Andrew Alm 2008-12-04 15:44:36 EST
I have tried to adjusting pulse audio's priority thinking maybe it was just not getting enough CPU time, but that doesn't seem to make the 'pop and clicks' go away.
Comment 4 rvcsaba 2008-12-06 07:44:06 EST
This is an ALSA bug? I remove pulseaudio and use ALSA with ogg123.

ogg123 *

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: 01 - Indokolatlan jkedv.ogg
Ogg Vorbis stream: 2 channel, 44100 Hz
Title: Indokolatlan jókedv
Artist: Bikini
Track number: 1
Tracktotal: 19
Album: Aranyalbum
Musicbrainz_sortname: Bikini
ALSA: underrun, at least 0ms.02:44.15  (174.1 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (158.3 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (161.0 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (168.3 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (166.4 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.
ALSA: underrun, at least 0ms.02:44.15  (162.8 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (165.3 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (167.1 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.
ALSA: underrun, at least 0ms.02:44.15  (166.3 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (157.6 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.02:44.15  (174.3 kbps)  Output Buffer  66.7%  
ALSA: underrun, at least 0ms.
                                                                           
Done.

I use Fedora 10 x86_64, AMD Phenom(tm) 9550 Quad-Core Processor, ca0106 (sb0410).
Comment 5 Lennart Poettering 2008-12-08 17:50:11 EST
Which ALSA sound driver is this?
Comment 6 rvcsaba 2008-12-08 18:16:15 EST
rpm -qa \*alsa\*
alsa-lib-1.0.18-6.rc3.fc10.x86_64
alsa-lib-devel-1.0.18-6.rc3.fc10.x86_64
alsa-utils-1.0.18-6.fc10.x86_64
alsa-lib-1.0.18-6.rc3.fc10.i386
bluez-alsa-4.19-1.fc10.x86_64

rpm -qa \*pulse\*
xine-lib-pulseaudio-1.1.15-3.fc10.x86_64
pulseaudio-libs-0.9.13-6.fc10.x86_64
pulseaudio-libs-0.9.13-6.fc10.i386

lsmod | grep snd
snd_hda_intel         476576  0 
snd_ca0106             43280  2                     <<--- This driver
snd_rawmidi            30848  1 snd_ca0106
snd_ac97_codec        121160  1 snd_ca0106
snd_seq_dummy          11396  0 
snd_seq_oss            39104  0 
snd_seq_midi_event     14848  1 snd_seq_oss
snd_seq                61968  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15380  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            52224  0 
snd_mixer_oss          23168  1 snd_pcm_oss
snd_pcm                85512  4 snd_hda_intel,snd_ca0106,snd_ac97_codec,snd_pcm_oss
snd_timer              30352  2 snd_seq,snd_pcm
ac97_bus               10112  1 snd_ac97_codec
snd_hwdep              16392  1 snd_hda_intel
snd                    68984  17 snd_hda_intel,snd_ca0106,snd_rawmidi,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
snd_page_alloc         16656  3 snd_hda_intel,snd_ca0106,snd_pcm
soundcore              14992  1 snd
Comment 7 Erik van Pienbroek 2008-12-09 03:01:29 EST
$ lsmod | grep snd
snd_hda_intel         476576  3 
snd_seq_dummy          11396  0 
snd_seq_oss            39104  0 
snd_seq_midi_event     14848  1 snd_seq_oss
snd_seq                61968  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15380  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            52224  0 
snd_mixer_oss          23168  1 snd_pcm_oss
snd_pcm                85512  2 snd_hda_intel,snd_pcm_oss
snd_timer              30352  2 snd_seq,snd_pcm
snd_page_alloc         16656  2 snd_hda_intel,snd_pcm
snd_hwdep              16392  1 snd_hda_intel
snd                    68984  16 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              14992  1 snd
Comment 8 Scott Doty 2008-12-10 15:55:48 EST
I had the same problem with f10... my sound device is an Intel HDA unit, and
so far, all complaints I've talked to folks about have been Intel HDA.

Same workaround as above, I removed the alsa->pulseaudio library, and just
use native alsa.

HTH.
Comment 9 rvcsaba 2008-12-10 16:14:34 EST
(In reply to comment #8)

> Same workaround as above, I removed the alsa->pulseaudio library, and just
> use native alsa.

Which packets removed? (See comment #6)
Comment 10 Lennart Poettering 2008-12-18 09:41:55 EST
Please don't hijack bug reports. Casey, which driver is this?
Comment 11 Casey Dahlin 2008-12-18 10:19:05 EST
[root@baudrillard ~]# lsmod | grep snd
snd_intel8x0           30876  3 
snd_intel8x0m          16780  0 
snd_ac97_codec         95264  2 snd_intel8x0,snd_intel8x0m
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48576  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16896  1 snd_pcm_oss
snd_pcm                65924  4 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_pcm_oss
snd_timer              22024  2 snd_seq,snd_pcm
snd                    50616  17 snd_intel8x0,snd_intel8x0m,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9416  1 snd
snd_page_alloc         11016  3 snd_intel8x0,snd_intel8x0m,snd_pcm
[root@baudrillard ~]# lspci | grep audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
Comment 12 Lennart Poettering 2008-12-21 09:07:45 EST
snd_intel8x0 is known to provide buggy timing information. I'd be interested to fix this one but I wasn't able to get any hardware with an snd-intel8x0 chip yet.
Comment 13 Lennart Poettering 2008-12-21 09:12:50 EST

*** This bug has been marked as a duplicate of bug 471804 ***

Note You need to log in before you can comment on or make changes to this bug.