This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 471804 - snd-intel8x0: Pulseaudio is dying and suffers from rare interruptions
snd-intel8x0: Pulseaudio is dying and suffers from rare interruptions
Status: CLOSED DUPLICATE of bug 472339
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
: 473695 (view as bug list)
Depends On: 479525
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 12:17 EST by antonio montagnani
Modified: 2009-06-21 15:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 09:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
after .29 kernel... (25.62 KB, application/octet-stream)
2009-02-20 14:49 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2008-11-16 12:17:57 EST
Description of problem:
Pulseaudio is dying and suffers from rare interruptions in Rhythmbox

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-6.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.start Rhythmbox
2.
3.
  
Actual results:
Some breaks and some seaths

Expected results:
Smooth sound

Additional info:

I attach a log of pulseaudio, I see that pulseaudio dies and some rewinds...
Comment 1 antonio montagnani 2008-11-16 12:19:45 EST
http://www.smolts.org/show?uuid=pub_2dabf29b-bd26-4825-b7ed-ac1db85fec24

Of course mine is an AC_97 problematic machine :-)

But situation is really improved
Comment 2 Bug Zapper 2008-11-26 00:28:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lennart Poettering 2008-12-08 18:05:48 EST
See no attachment
Comment 4 Lennart Poettering 2008-12-21 09:11:40 EST
Hmm, are you using the nvidia closed source driver? It severely inteferes with the process scheduling of the Linux kernel causing PA to miss the deadlines more often.
Comment 5 Lennart Poettering 2008-12-21 09:12:50 EST
*** Bug 473695 has been marked as a duplicate of this bug. ***
Comment 6 Scott Doty 2008-12-21 15:07:26 EST
I am using snd-hda-intel, which exhibits the problem with the pulseaudio alsa emulation libraries.  Removing those libraries and using native alsa solves the problem.

(I also have one application for which I am using the alsa oss emulation to a usb audio device -- works like a champ, once I got the levels squared-away.)

And yes, I'm using the proprietary nvidia driver.

Anything I can do to help you with this?  I'll even buy a mobo with intel hda, if it would help...if you'd like that, where shall I drop-ship it?

 -Scott
Comment 7 Scott Doty 2008-12-21 15:53:27 EST
(In reply to comment #6)
> I am using snd-hda-intel, which exhibits the problem with the pulseaudio alsa
> emulation libraries.  Removing those libraries and using native alsa solves the
> problem.

I just re-installed the pulse libraries...playback is working, I don't hear any
clicks, even when using compiz with the "dodge" focus effect.

Tried moving output from mplayer to another device, mplayer got stuck running nanosleep()'s...

Restarted mplayer, now I can move streams between devices, works okay.

I'll keep using pulseaudio until (heaven forbid) something breaks...hopefully
it will "just work" now. :)

 -Scott
Comment 8 antonio montagnani 2009-02-20 14:49:07 EST
Created attachment 332747 [details]
after .29 kernel...

I updated the system to .29 kernel and system is fully updated.
This attachment is the output of pulseaudio --vv, as I am suffering of small and rare interruptions (now rewinds are only 256 or 328 bytes...) 

I am running with no option in modprobe.conf

alias eth0 ne2k-pci
alias eth1 skge
alias scsi_hostadapter libata
alias scsi_hostadapter1 ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
#options snd-intel8x0 index=0 ac97_clock=48000
#options snd-intel8x0 index=0 ac97_clock=44100
#options snd-intel8x0 index=0 ac97_clock=41194
options snd-intel8x0 index=0
alias snd-card-1 snd-mpu401
options snd-card-1 index=1
options snd-mpu401 index=1

shall I test with ac97_clock=44100 as per the first lines of the attachment??
Comment 9 antonio montagnani 2009-02-20 15:23:39 EST
I have tested with ac97_clock=44100 and sound is almost as it should be.
Any other information that I can supply???
Comment 10 antonio montagnani 2009-02-21 10:27:17 EST
interruptions are still there (not so evident anyway..), even if situation has improved a lot.

I think that there too many bugs around for same problem (especially for hda driver).
But I don't know if and how they can be merged (solution should be easier if bugs are joined..)
Comment 11 antonio montagnani 2009-03-08 12:29:01 EDT
and finally adding tsched=0 to load-module module-hal-detect in /etc/pulse/default.pa, let me have sound as it should be!!!
I changed two lines (I have found load-module module-hal detect line twice..)

no other tweak required on my fully updated F11 system.
Comment 12 Lennart Poettering 2009-03-24 15:20:21 EDT
The bug is not fixed yet. tsched=0 is a workaround, not a fix.
Comment 13 Lennart Poettering 2009-04-02 09:59:45 EDT

*** This bug has been marked as a duplicate of bug 472339 ***
Comment 14 Alex Butcher 2009-06-21 15:00:05 EDT
Lennart wrote:

> Hmm, are you using the nvidia closed source driver? It severely inteferes with
> the process scheduling of the Linux kernel causing PA to miss the deadlines
> more often. 

Is there any workaround for that? (other than "don't use the nVidia closed source driver, dummy!"); is tsched=0 the best we can do on a system that uses the nVidia driver?

Note You need to log in before you can comment on or make changes to this bug.