Bug 473807 - amarok does not see media players
amarok does not see media players
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-30 14:37 EST by Bob Arendt
Modified: 2009-04-26 12:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 09:45:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Arendt 2008-11-30 14:37:51 EST
Description of problem:
Previous versions of amarok (1.4.10) had a facility for syncing to my media player.  Songs or downloaded podcasts could be selected to transfer to this USB/UMS mounted media player.  It appears that amarok2 tries to provide this via a "Media Devices" applet - it creates a blank panel in the center of the display.  But no menu options will configure it, and a right-mouse in the area only has the option to remove the "Media Devices" applet.  This is a significant regression with respect to the capability present in Fedora9.

Version-Release number of selected component (if applicable):
amarok-1.94-2.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. Plug in and mount USB/UMS media device
2. start amarok
3. In center pane, click the green plus, and click "Media Devices" to add something to help manage media devices (?)
  
Actual results:
Creates a blank panel in the center pane.  The panel only responds to a right mouse click, with the option to "Add Applet" (same as green plus) or "Remove this Media Devices".  No additional items or configuration options are added to the application menus.

Expected results:
Some facility to identify folders on the media device, and a way to transfer and sync to the device.

Additional info:
I'd RTFM .. but the help files don't exist.  See Bug#473522
Comment 1 Bob Arendt 2008-11-30 20:57:33 EST
No change in amarok-1.98-1.fc10.i386.rpm from updates-testing.
Comment 2 Rex Dieter 2008-12-01 08:59:25 EST
I'm not sure if this counts as "USB mass storage devices support", per
http://amarok.kde.org/blog/archives/809-Missing-features-in-Amarok-2.html

I'll try asking the devs.
Comment 3 Bob Arendt 2008-12-01 10:01:39 EST
Yes, this does sound like the issue.  The iRiver T10 (UMS version) shows up as USB external storage.  This is a pretty common way that non-Apple, non-Microsoft mp3 players are configured.  And I believe that all (?) Rockbox (http://www.rockbox.org/) players connect this way.  Thanks for checking in with the devs.
Comment 4 Fedora Update System 2008-12-02 20:11:07 EST
amarok-1.98-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Bob Arendt 2008-12-02 21:10:38 EST
Closed this one by accident.

This issue still exists with amarok-1.98-1.fc10.
Comment 6 Rex Dieter 2008-12-23 10:30:06 EST
and amarok-2.0

(I really need to "borrow" the wife's ipod to try this out myself).

In short, in amarok, click + in middle pane, add the "media devices" applet.  Does it show anything?
Comment 7 Bob Arendt 2008-12-23 23:35:43 EST
Just checked with amarok-2.0-2.fc10.i386 (nothing newer in updates-testing)

Same behaviour.  It adds a grey region (faint border).  No buttons, controls, or menus.  The only mouse button that has any effect is the right one.  It has the options:
  (green plus)  Add Applet ...
  (red X)       Remove this media device

Add Applet brings up the same Applet menu used to add the "Media Device" in the first place.  The "Add Applet" actions don't have any affect on the existing Media Device panel.  The "Remove" option will remove the Media Device panel.

I checked the Settings/Configure Amarok options, and there don't appear to be any config actions added relating to media devices when I added the panel.

Perhaps the "Add Applet" action should really be some kind of "Configure Media Device" callback.  Possibly the functionality exists, but the wrong action was mapped to the mouse menu?

Could there be an undocumented helper utility to configure it?

But as you previously noted ... it looks like it's still "to be implemented".
From http://amarok.kde.org/ , dated December 10, 2008:
   ....
Because of the major changes required, not all features from the 1.4 are in Amarok 2. Many of these missing features, like queueing and filtering in the playlist, will return within a few releases. Other features, such as visualizations and support for portable media players, require improvements in the underlying KDE infrastructure. They will return as KDE4's support improves.
  ....

My 12-year daughter didn't think too highly of F10 when I updated her and she couldn't sync her MP3 player.  Good thing I could install the F9 Amarok 1.4 rpms and get her back online.  Hopefully F9 doesn't get "upgraded" before Amarok2 matures a bit more.  That said I think Amarok2 has a lot of potential, I'm sticking with it.
Comment 8 Steven M. Parrish 2009-01-09 15:27:40 EST
Upstream is aware of this.  Player support is pending.  Will keep this updated with progress.
Comment 9 Andrew Gilmore 2009-03-04 10:35:18 EST
(In reply to comment #7)
> 
> My 12-year daughter didn't think too highly of F10 when I updated her and she
> couldn't sync her MP3 player.  Good thing I could install the F9 Amarok 1.4
> rpms and get her back online.  Hopefully F9 doesn't get "upgraded" before
> Amarok2 matures a bit more.  That said I think Amarok2 has a lot of potential,
> I'm sticking with it.

Which F9 RPMS did you have to install to get amarok 1.4 to work on F10? 
I upgraded my laptop to F10, and now can't sync any of my media devices. :(

Andrew
Comment 10 Bob Arendt 2009-03-04 11:31:36 EST
As a workaround, that was amarok-1.4.10-2.fc9.i386.rpm, available here:
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/i386.newkey/amarok-1.4.10-2.fc9.i386.rpm
.. or your favourite local F9 repo mirror (updates-newkey).  The associated amarok-visualisation-1.4.10-2.fc9.i386.rpm is there as well.
Comment 11 Andrew Gilmore 2009-03-04 15:01:35 EST
(In reply to comment #10)
> As a workaround, that was amarok-1.4.10-2.fc9.i386.rpm, available here:

Hmm, seems to mostly work, except transfers to generic USB media devices, when it freezes.

I also rebuilt it as native F10 without Helix and mtp, and had the same problem.

This is one area where I wish the amarok maintainers had packaged amarok2 separately, since it is so lacking, and will continue to be for some time to come.

Note You need to log in before you can comment on or make changes to this bug.