Bug 473875 - Arrows and some other keys are not working
Arrows and some other keys are not working
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dosbox (Show other bugs)
10
All Linux
high Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 474411 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 03:39 EST by Michal Hlavinka
Modified: 2009-03-16 15:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.72-5.fc10.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 15:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2008-12-01 03:39:30 EST
Description of problem:
Arrows and some other keys on the right side of keyboard are not working.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.run someting in dosbox
2.try to use arrows
3.
  
Actual results:
nothing happens

Expected results:
all keys working

Additional info:
this looks similiar to problem with X server, where keys wasn't working because of new evdev driver

also qemu (#471000) is known to have the same problem with arrow keys. I don't know, but *maybe* it can be somehow related?
Comment 1 Kai Hambrecht 2008-12-02 11:45:13 EST
i can confirm this. It's an issue with "evdev" driver and not only related to dosbox but also to other (e.g. qemu, vmware). Removing "evdev" and using old "kbd" fixes this. See also Bug #471000
Comment 2 Andreas Bierfert 2008-12-04 00:26:51 EST
*** Bug 474411 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2009-03-08 18:22:03 EDT
dosbox-0.72-5.fc10.1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/dosbox-0.72-5.fc10.1
Comment 4 Fedora Update System 2009-03-09 19:07:35 EDT
dosbox-0.72-5.fc10.1 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dosbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2546
Comment 5 Fedora Update System 2009-03-16 15:40:22 EDT
dosbox-0.72-5.fc10.1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.