Bug 473884 - Subnet mask in manual IPV4 configuration shows the same value of gateway
Subnet mask in manual IPV4 configuration shows the same value of gateway
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 05:22 EST by Volans
Modified: 2008-12-01 05:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 05:44:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Volans 2008-12-01 05:22:47 EST
Description of problem:

Upon making a static configuration of a network connection, the shown value of the subnet mask equals the one of the gateway


Version-Release number of selected component (if applicable): 1.5.93

How reproducible:

Just setup your network manually and then press another tab of the network config ("route" for example) and then go back to the "General" tab. The shown subnet mask will be the same as the gateway.

Steps to Reproduce:

1. Open System-config-network.
2. Select the wired connection you wish to put a static IP on.
3. Press "Edit".
4. Select "Statically set IP addresses".
5. Put your settings.
6. Press the "Route" or "Hardware device" tab.
7. Go back to the "General" tab.
8. You'll notice the subnet mask is now the same as the gateway.
  
Actual results:


Expected results:


Additional info:

The subnet mask actually gets the value you want (I checked with ifconfig), but the correct value isn't shown in system-network config.
Comment 1 Jiri Moskovcak 2008-12-01 05:44:18 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.