Bug 473951 - Applications should indicate which user is running them.
Applications should indicate which user is running them.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 11:02 EST by Linuxguy123
Modified: 2009-02-04 07:28 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 07:28:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linuxguy123 2008-12-01 11:02:24 EST
Description of problem:

Some applications will get run as root from time to time.   Dolphin, Konqueror, ark, KpackageManager, Kwrite, etc.    These applications do now indicate what user is running them.  It is impossible to distinguish between a Dolphin running as a regular user and a Dolphin running as root.  

I am making this entry for Dolphin, because I regularly use it as a root user, but the same argument could be made for the other applications as well.

Version-Release number of selected component (if applicable):

$ yum list kdebase
Loaded plugins: kmdl, priorities, refresh-packagekit
0 packages excluded due to repository priority protections
Installed Packages
kdebase.i386                                       6:4.1.3-2.fc10                                       installed

How reproducible:

Everytime.


Steps to Reproduce:
1. Kickstart->Dolphin->Add to Desktop

2. Dolphin Icon->Icon Settings -> Application -> Advanced 
Enable Run as different user.  Enter root.  Press OK all the way out to save.

3. Click the desktop icon to start Dolphin.  Give the root password.  Dolphin starts.
  
Actual results:

There is no indication who owns this Dolphin instance.  

Expected results:

I think it should say something like Dolphin as root or something in the title bar.  If I have 2 Dolphin instances open, I can't tell which is root and which is normal user.  

I know that Konqueror in KDE 3.5 used to display who owned the instance.  I found this very useful.    

Thanks for listening.
Comment 1 Chitlesh GOORAH 2008-12-01 13:12:25 EST
As per,
https://bugzilla.redhat.com/show_bug.cgi?id=473959#c1, I'm reassigning this bug.
Comment 2 Steven M. Parrish 2009-01-09 14:19:04 EST
This needs to be reported upstream at http://bugs.kde.org  then please add upstream info to this report and we will monitor for a resolution.
Comment 3 Kevin Kofler 2009-01-09 15:51:09 EST
Is this even a bug in the first place?
I guess filing it upstream with Severity: wishlist is the best solution.
Comment 4 Jaroslav Reznik 2009-01-12 04:05:22 EST
It makes sense to Dolphin to indicate if it is running under root account.
Comment 5 Steven M. Parrish 2009-02-04 07:27:58 EST
Your right it would be nice for Dolphin to do this, however it is not a bug but a feature request.  Please add your request to the upstream wishlist.

Note You need to log in before you can comment on or make changes to this bug.