Bug 474155 - scc and poorly formed xml error for vm resource
scc and poorly formed xml error for vm resource
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks: 474158
  Show dependency treegraph
 
Reported: 2008-12-02 10:21 EST by Shane Bradley
Modified: 2016-04-26 11:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the issues (262 bytes, patch)
2008-12-02 10:22 EST, Shane Bradley
no flags Details | Diff

  None (edit)
Description Shane Bradley 2008-12-02 10:21:21 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc9 Firefox/3.0.4

Configured VM service in cluster through luci which propagated the
following :

<vm autostart="1" domain="bias-satxen1" exclusive="0" migrate="live" name="razorback" path="/guest_roots" recovery="restart"/>

then the system-config-cluster throws below error :

/etc/cluster/cluster.conf:33: element vm: Relax-NG validity error : Invalid attribute migrate for element vm
Relax-NG validity error : Extra element rm in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster failed to validate content
/etc/cluster/cluster.conf fails to validate

When he edit the cluster.conf and take out the migrate="live"
parameter, the XML error window does not appear.

--------------------------------------------------------------------------------

The problem is with the xml in
/usr/share/system-config-cluster/misc/cluster.ng

I have added a patch that does the following:

1) changes migration to migrate

2) made domain optional instead of required in vm section



Reproducible: Always

Steps to Reproduce:
1. Create a vm service and with live migration
2. open the file with system-config-cluster

Actual Results:  
xml errors are given

Expected Results:  
No xml errors
Comment 1 Shane Bradley 2008-12-02 10:22:20 EST
Created attachment 325379 [details]
patch to fix the issues
Comment 5 Chris Ward 2010-02-11 05:12:26 EST
~~ Attention Customers and Partners - RHEL 5.5 Beta is now available on RHN ~~

RHEL 5.5 Beta has been released! There should be a fix present in this 
release that addresses your request. Please test and report back results 
here, by March 3rd 2010 (2010-03-03) or sooner.

Upon successful verification of this request, post your results and update 
the Verified field in Bugzilla with the appropriate value.

If you encounter any issues while testing, please describe them and set 
this bug into NEED_INFO. If you encounter new defects or have additional 
patch(es) to request for inclusion, please clone this bug per each request
and escalate through your support representative.
Comment 6 Brian Brock 2010-03-09 17:21:29 EST
fix verified in system-config-cluster-1.0.57-3

xmllint now validates with migrate="live" inside the <vm /> tag
Comment 10 Shane Bradley 2010-03-19 13:43:27 EDT
Fix verified with comment: https://bugzilla.redhat.com/show_bug.cgi?id=474155#c6
Comment 11 errata-xmlrpc 2010-03-30 04:54:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0288.html

Note You need to log in before you can comment on or make changes to this bug.