Bug 474158 - scc and poorly formed xml error for vm resource
scc and poorly formed xml error for vm resource
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On: 474155
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 10:25 EST by Shane Bradley
Modified: 2010-02-15 15:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-15 15:37:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Bradley 2008-12-02 10:25:36 EST
+++ This bug was initially created as a clone of Bug #474155 +++

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc9 Firefox/3.0.4

Configured VM service in cluster through luci which propagated the
following :

<vm autostart="1" domain="bias-satxen1" exclusive="0" migrate="live" name="razorback" path="/guest_roots" recovery="restart"/>

then the system-config-cluster throws below error :

/etc/cluster/cluster.conf:33: element vm: Relax-NG validity error : Invalid attribute migrate for element vm
Relax-NG validity error : Extra element rm in interleave
/etc/cluster/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster failed to validate content
/etc/cluster/cluster.conf fails to validate

When he edit the cluster.conf and take out the migrate="live"
parameter, the XML error window does not appear.

--------------------------------------------------------------------------------

The problem is with the xml in
/usr/share/system-config-cluster/misc/cluster.ng

I have added a patch that does the following:

1) changes migration to migrate

2) made domain optional instead of required in vm section



Reproducible: Always

Steps to Reproduce:
1. Create a vm service and with live migration
2. open the file with system-config-cluster

Actual Results:  
xml errors are given

Expected Results:  
No xml errors

--- Additional comment from sbradley@redhat.com on 2008-12-02 10:22:20 EDT ---

Created an attachment (id=325379)
patch to fix the issues
Comment 1 Lon Hohberger 2010-02-15 15:37:16 EST
Red Hat Cluster Suite 4 does not ship nor support VM resources.

Note You need to log in before you can comment on or make changes to this bug.