Bug 474275 - Traceback in network config dialog - no attribute 'gateway'
Traceback in network config dialog - no attribute 'gateway'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 481142 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 21:21 EST by Pavel Roskin
Modified: 2009-02-20 23:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt produced on anaconda (63.06 KB, text/plain)
2008-12-02 21:21 EST, Pavel Roskin
no flags Details

  None (edit)
Description Pavel Roskin 2008-12-02 21:21:43 EST
Created attachment 325468 [details]
anacdump.txt produced on anaconda

Description of problem:
Changing network interface after configuring it for static IP causes a traceback in the installer.

Version-Release number of selected component (if applicable):
11.4.1.62

How reproducible:
always

Steps to Reproduce:
1. Run installation from Fedora 10 i386 DVD with all defaults on a system with more than one network interface.
2. Select "Advanced Storage Configuration"
3. Select "Add iSCSI target"
4. For the first interface (eth0 in my case), uncheck DHCP, enter IP 192.168.0.23/255.255.255.0, gateway 192.168.0.1, nameserver 192.168.0.1
5. Press "OK".  After some time, an error message appears "Error configuring network device".  Dismiss the message by pressing "OK".
6. Select another network interface (eth1 in my case).  I'm doing it with the keyboard, as I have no mouse on that system.
7. Select the original network interface (eth0).
  
Actual results:
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 79, in _netdevChanged
    if self.network.gateway: self.xml.get_widget("gatewayEntry").set_text(self.network.gateway)
AttributeError: Network instance has no attribute 'gateway'

Expected results:
There should be no error configuring the network device in the first place.  And if there is any error, there should be no traceback!

Additional info:
Comment 1 David Cantrell 2008-12-05 15:08:38 EST
Patch accepted, will push changes to git repository once git.fedorahosted.org comes back online.

The next build of anaconda in rawhide will contain this fix.  When you can verify it works, please mark this bug as CLOSED RAWHIDE.
Comment 2 David Cantrell 2009-02-20 23:31:23 EST
*** Bug 481142 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.