Bug 474406 - yum-complete-transaction crashes: NameError: global name 'os' is not defined
yum-complete-transaction crashes: NameError: global name 'os' is not defined
Status: CLOSED DUPLICATE of bug 470458
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 13:00 EST by Tom London
Modified: 2014-01-21 18:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 13:03:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-12-03 13:00:18 EST
Description of problem:

[root@tlondon sbin]# yum-complete-transaction --cleanup-only
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
Cleaning up unfinished transaction journals
Cleaning up 2008-12-03.06:22.00
Traceback (most recent call last):
  File "/usr/sbin/yum-complete-transaction", line 208, in <module>
    util = YumCompleteTransaction()
  File "/usr/sbin/yum-complete-transaction", line 115, in __init__
    self.main()
  File "/usr/sbin/yum-complete-transaction", line 163, in main
    self.clean_up_ts_files(timestamp, self.conf.persistdir)
  File "/usr/sbin/yum-complete-transaction", line 123, in clean_up_ts_files
    if os.path.exists(f):
NameError: global name 'os' is not defined
[root@tlondon sbin]# 

Had a failure/hang during a previous 'yum update'.

'yum-complete-transaction' says:
[root@tlondon bin]# yum-complete-transaction 
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 48 elements left to run
--> Running transaction check
---> Package policycoreutils.x86_64 0:2.0.60-1.fc11 set to be erased
--> Processing Dependency: policycoreutils for package: anaconda
---> Package policycoreutils-gui.x86_64 0:2.0.60-1.fc11 set to be erased
--> Running transaction check
---> Package anaconda.x86_64 0:11.4.1.62-1 set to be erased
--> Finished Dependency Resolution

================================================================================
 Package                  Arch        Version              Repository      Size
================================================================================
Removing:
 policycoreutils          x86_64      2.0.60-1.fc11        installed      3.8 M
 policycoreutils-gui      x86_64      2.0.60-1.fc11        installed      840 k
Removing for dependencies:
 anaconda                 x86_64      11.4.1.62-1          installed       17 M

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       3 Package(s)         

Is this ok [y/N]: n
Exiting on user Command
Not removing old transaction files
[root@tlondon bin]# 

I do NOT want to remove this version of policycoreutils* (nor anaconda).

I manually reverted policycoreutils after update failure and before running yum-complete-transaction.

Version-Release number of selected component (if applicable):
yum-utils-1.1.18-2.fc11.noarch

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 seth vidal 2008-12-03 13:03:57 EST

*** This bug has been marked as a duplicate of bug 470458 ***

Note You need to log in before you can comment on or make changes to this bug.