Bug 470458 - Traceback from yum-complete-transaction
Traceback from yum-complete-transaction
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 470612 470624 470690 474406 475252 477075 (view as bug list)
Depends On:
Blocks: 470776
  Show dependency treegraph
 
Reported: 2008-11-07 05:05 EST by Tim Waugh
Modified: 2014-01-21 18:06 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 14:11:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum-complete-transaction-traceback.txt (15.54 KB, text/plain)
2008-11-07 05:06 EST, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2008-11-07 05:05:15 EST
Description of problem:
I got a traceback from yum-complete-transaction:

Traceback (most recent call last):
  File "/usr/sbin/yum-complete-transaction", line 208, in <module>
    util = YumCompleteTransaction()
  File "/usr/sbin/yum-complete-transaction", line 115, in __init__
    self.main()
  File "/usr/sbin/yum-complete-transaction", line 195, in main
    self.clean_up_ts_files(timestamp, self.conf.persistdir)
  File "/usr/sbin/yum-complete-transaction", line 123, in clean_up_ts_files
    if os.path.exists(f):
NameError: global name 'os' is not defined

Version-Release number of selected component (if applicable):
yum-utils-1.1.18-1.fc10

How reproducible:
Don't know.

Steps to Reproduce:
1.I just ran 'yum-complete-transaction' after interrupting an update.
  
Actual results:
Complete output attached.
Comment 1 Tim Waugh 2008-11-07 05:06:47 EST
Created attachment 322836 [details]
yum-complete-transaction-traceback.txt
Comment 2 Tim Waugh 2008-11-07 05:07:46 EST
Looking more closely I see that yum-utils was one of the packages updated, so actually it was yum-utils-1.1.17-2.fc10 that gave the traceback.
Comment 3 seth vidal 2008-11-07 08:53:58 EST
was yum being updated, too, when your transaction died?
Comment 4 seth vidal 2008-11-07 08:58:26 EST
also try this yum-complete-transaction

and tell me if it fixes it

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=blob;f=yum-complete-transaction.py;h=17ef3c8979a6493e62c3099768fc1a4b74a2f0da;hb=19a9ab41fc1f3eb2051287c870521edbae3f98a1

or at least changes the problem.
Comment 5 seth vidal 2008-11-08 01:10:39 EST
*** Bug 470612 has been marked as a duplicate of this bug. ***
Comment 6 seth vidal 2008-11-08 01:16:52 EST
*** Bug 470624 has been marked as a duplicate of this bug. ***
Comment 7 Tim Lauridsen 2008-11-09 01:11:06 EST
*** Bug 470690 has been marked as a duplicate of this bug. ***
Comment 8 DarkMoS 2008-11-09 09:15:44 EST
(In reply to comment #4)
> also try this yum-complete-transaction
> 
> and tell me if it fixes it
> 
> http://yum.baseurl.org/gitweb?p=yum-utils.git;a=blob;f=yum-complete-transaction.py;h=17ef3c8979a6493e62c3099768fc1a4b74a2f0da;hb=19a9ab41fc1f3eb2051287c870521edbae3f98a1
> 
> or at least changes the problem.

Hi, it did solve the issue for me. 
I had 9 'outstanding' transactions to complete (lot of them being from 2007) and everything is finally cleaned up after executing your modified yum-complete-transaction with --cleanup-only parameter (otherwise it was trying to reinstall 1200 packages). 
I wonder if it's not some leftovers of past preupgrade interrupted processes that are now taken into account because there was some fc7 in the packages it was checking.
Comment 9 Nic Doye 2008-11-11 17:48:01 EST
I had the power go while updating tonight - the only "package/yum" related update being gnome-packagekit-0.3.9-8.fc10.i386.

Like the reporter, I had the same traceback from yum-complete-transaction. Similarly, running the version from git "works" (sans command-line arguments) but leaves me wondering if my system is in a sane state...

nic
Comment 10 seth vidal 2008-11-11 21:49:09 EST
your system should be.

when in doubt - run:

package-cleanup --problems

and see what shows up.
Comment 11 Tim Waugh 2008-11-12 05:33:38 EST
I don't know if yum was being updated when the transaction failed.

(In reply to comment #4)
> also try this yum-complete-transaction
> and tell me if it fixes it

Yes, this fixes it.
Comment 12 Bug Zapper 2008-11-25 23:57:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 seth vidal 2008-12-03 13:03:57 EST
*** Bug 474406 has been marked as a duplicate of this bug. ***
Comment 14 Tom London 2008-12-03 13:16:37 EST
(In reply to comment #4)
> also try this yum-complete-transaction
> 
> and tell me if it fixes it
> 
> http://yum.baseurl.org/gitweb?p=yum-utils.git;a=blob;f=yum-complete-transaction.py;h=17ef3c8979a6493e62c3099768fc1a4b74a2f0da;hb=19a9ab41fc1f3eb2051287c870521edbae3f98a1
> 
> or at least changes the problem.

This fixes for me:

[root@tlondon Download]# python yum-complete-transaction.py --cleanup-only
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rawhide: mirrors.kernel.org
Cleaning up unfinished transaction journals
Cleaning up 2008-12-03.06:22.00
[root@tlondon Download]#
Comment 15 seth vidal 2008-12-08 12:38:03 EST
*** Bug 475252 has been marked as a duplicate of this bug. ***
Comment 16 Jóhann B. Guðmundsson 2008-12-08 13:03:55 EST
Also for me..
Comment 17 Horst H. von Brand 2008-12-09 16:52:46 EST
(In reply to comment #4)
> also try this yum-complete-transaction
> 
> and tell me if it fixes it
> 
> http://yum.baseurl.org/gitweb?p=yum-utils.git;a=blob;f=yum-complete-transaction.py;h=17ef3c8979a6493e62c3099768fc1a4b74a2f0da;hb=19a9ab41fc1f3eb2051287c870521edbae3f98a1
> 
> or at least changes the problem.

Fixes it for me here (I also saw the problem on updating a bunch, probably including yum-utils, and then on).

Saw it on yum-utils-1.1.18-2.fc11.noarch, with python-2.6-1.fc11.x86_64
Comment 18 seth vidal 2008-12-10 14:11:35 EST
closing -> upstream
Comment 19 Fedora Update System 2008-12-18 09:05:27 EST
yum-utils-1.1.19-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-utils-1.1.19-1.fc10
Comment 20 Fedora Update System 2008-12-18 09:05:34 EST
yum-utils-1.1.19-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/yum-utils-1.1.19-1.fc9
Comment 21 seth vidal 2008-12-18 22:19:33 EST
*** Bug 477075 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2009-01-07 04:14:47 EST
yum-utils-1.1.19-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2009-01-07 04:15:07 EST
yum-utils-1.1.19-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.