Bug 474477 - Very low mic capture volume
Very low mic capture volume
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 17:53 EST by Aniket
Modified: 2010-06-09 06:35 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:08:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aniket 2008-12-03 17:53:26 EST
Description of problem:
I have the default setup with pulseaudio enabled. In gnome sound preferences the playback devices are set to "Autodetect" and capture to "ALSA" . I have also tried with capture device as "HDA Intel :Analog" . In both cases the volume of the sound captured from the microphone is very low. I have tried with gnome-sound-recorder and even with skype (setting SOund Out to "pulse" and Sound In to "HDA Intel (hw:intel,0)" . In both apps the recorded volume is very low.
I have tried adjusting all volume sliders in gnome-volume-control and Kmix, and it doesnt show any improvement. All sliders are at 100% still I get low mic volume. 

If I remove pulseaudio, recording is fine, but then the phonon-xine-backend for KDE uses the device "HDA Intel STAC92XX (Analog)" for output and blocks sound from all other apps like flash player in browsers , mplayer etc. So I have to enable gstreamer-backend (using output device "Default" for dmix) which works, but is not as good as phonon-xine-backend when it comes to apps like Amarok (multimedia metadata doesnt load well , some internet stations dont play etc)
 
Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-6.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1.Open gnome-sound-recorder
2.Start recording
3.Play the recorded clip
  
Actual results:
Volume captured is very low. 

Expected results:
Recording volume should have been normal. 


I have said severity as "high" because I noticed by searching the net that this problem affects all laptops with Intel HDA sound chips and built in digital microphohes. Also, removing pulseaudio (which was the simplest solution and worked in F9) creates more problems with xine-backend in KDE resulting in KDE capturing the sound output exclusively. Swicthing to gstreamer backend produces a sub-standard multimedia expreience with Amarok. So its a bug-dependency hell!!

I submitted a bug report as to why phonon-xine-backend doesnt support alsa device usage via dmix (https://bugzilla.redhat.com/show_bug.cgi?id=474259) , and the response there indicates that its intentional to not have xine-backend use alsa directly, which compounds the problem. 

Additional info:
The bug report with pulseaudio : http://www.pulseaudio.org/ticket/423
Similar bug on Ubuntu Launchpad: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/282931 

and 
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/261018

PS : here is my lspci output:

00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port [8086:2a01] (rev 0c) 
00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 02)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 02)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 02)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 [8086:2845] (rev 02)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 [8086:2849] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 02)
00:1f.2 SATA controller [0106]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [8086:2829] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 02)
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M GS [10de:0427] (rev a1)
03:01.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
03:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
03:01.2 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 12)
03:01.3 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 12)
03:01.4 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev ff)
09:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express [14e4:1713] (rev 02)
0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)
Comment 1 thibaut.sardan 2008-12-03 19:11:30 EST
Same for me, I add that even if the microphone is muted, it can record at a very very low volume..(in my case with the same ICH8 family Audio device the microphone auto-mute, when I unmute it, close the window of the manager, and re-open it, the microphone has been re-muted automaticly..), I have this problem also in Ubuntu 8.10 and F10
Comment 2 Aniket 2008-12-03 23:19:42 EST
What additional info is needed? I am more than happy to assist in solving this bug
Comment 3 Lennart Poettering 2008-12-08 14:21:37 EST
If you set Capture to "ALSA" the PA will bypassed. If the vlume is too low it is certainly not a PA problem. Most likely it is a just a matter of playing around with the alsa volume controls. try "alsamixer -c0" and then switch to "Capture". If that's not the case it is a driver issue.

Reassigning to ALSA.
Comment 4 Samuel Audet 2009-01-02 21:21:49 EST
I have the same problem on my Dell XPS M1330 with latest BIOS, A12 IIRC.. I'm running Fedora 10 with all the latest updates ... I tried the fix from thread on launchpad, but it doesn't work. For exampel, using the following ~/.asoundrc

pcm.newdevice {
    type            softvol
    slave.pcm       "hw:0,0"
    control.name    "Softmaster"
    control.card    0
}

and running "arecord -D newdevice -f S16_LE -c2 -r44100 moo.wav" produces a "Segmentation fault". Skype also crashes. Veeery frustrating.

The only big difference between Ubuntu and Fedora at this point seems to be the version of ALSA: 1.0.17 for Ubuntu and 1.0.18 for Fedora. 

ALSA and Pulse are a disaster... If I can do anything to debug this or any of the other bug reports related to ALSA/Pulse and happening on the XPS M1330, please let me know what to try, thanks
Comment 5 intrepiduser 2009-01-02 22:42:15 EST
this launchpad thread https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/275998 contains a workaround for this annoying bug that saved my Dell 1525! Look at comment 109 onwards, it creates some sort of alsaboost to counter the lack of a micboost in pulseaudio and then runs pulseaudio on top of that. I can now run arecord and Gnome Sound Recorder at the same time, with micboost! yeah!
Comment 6 Samuel Audet 2009-01-02 23:53:38 EST
intrepiduser: it works, really? Are you running Fedora 10? Can you post the exact asound.conf/.asoundrc you are using? Thanks
Comment 7 Samuel Audet 2009-01-03 13:16:49 EST
Oh boy, ALSA 1.0.18 really is the reason why the trick on launchpad doesn't work for Fedora... Here is one way to downgrade to 1.0.17 so we can FINALLY use internal microphones on all those lovely laptops with Fedora 10. First download alsa-lib 1.0.17:
    ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.17.tar.bz2
And untar somewhere:
    tar -xjvf alsa-lib-1.0.17.tar.bz2
    cd alsa-lib-1.0.17

Then, for x86_64 systems:
    ./configure --libdir=/usr/lib64
    make
    sudo mv /lib64/libasound.so.2.0.0 /lib64/libasound.so.2.0.0_buggy
    sudo cp src/.libs/libasound.so.2.0.0 /lib64/libasound.so.2.0.0
    sudo yum install python-devel.i386 glibc-devel.i386
    make clean
    CFLAGS="-m32" LDFLAGS="-m32" ./configure --target=i386-pc-linux-gnu
    make
    sudo mv /lib/libasound.so.2.0.0 /lib/libasound.so.2.0.0_buggy
    sudo cp src/.libs/libasound.so.2.0.0 /lib/libasound.so.2.0.0

Or for i386 systems:
    ./configure
    make
    sudo mv /lib/libasound.so.2.0.0 /lib/libasound.so.2.0.0_buggy
    sudo cp src/.libs/libasound.so.2.0.0 /lib/libasound.so.2.0.0

ONE LAST VERY IMPORTANT NOTE: Fedora 10 seems to incorporate new tricks that will change symbolic links dynamically... sometimes... Make sure the links at /lib/libasound.so.2 and /lib64/libasound.so.2 point to the newly compiled file and not the "buggy" ones...

Then, if you create a ~/.asoundrc file in your home directory such as this one:

    pcm.loudmic {
        type asym
        capture.pcm {
            type softvol
            slave.pcm "hw:0,0"
            control {
                name "Mic Boost"
                card 0
            }
            max_dB 20.0
        }
    }

You will get a shiny new "Mic Boost" control in the mixer preferences, and if you select "loudmic" as your input source in Skype, the sound will be accordingly amplified.. And check the threads on launchpad for other fun tricks

ALSA and Pulse are buggy buggy... please someone acknowledge that ALSA and PulseAudio have too many _severe_ bugs :) And please let us know how we can help the ALSA and Pulse teams to fix all these problems :) Thank you
Comment 8 Samuel Audet 2009-01-13 10:18:26 EST
This is from sound/Documentation/HD-Audio.txt of the alsa-driver package:

"When the PCM device is opened via "default" PCM (without pulse-audio
plugin), you'll likely have "Digital Capture Volume" control as well.
This is provided for the extra gain/attenuation of the signal in
software, especially for the inputs without the hardware volume
control such as digital microphones.  Unless really needed, this
should be set to exactly 50%, corresponding to 0dB -- neither extra
gain nor attenuation.  When you use "hw" PCM, i.e., a raw access PCM,
this control will have no influence, though."


Conclusion:

When using pulseaudio, we need to install our own "Digital Capture Volume" such as described in my previous comment... which should be added to /etc/asound.conf in default Fedora installation. Comments?

Thankfully, the rest of pulseaudio works great in Fedora, contrarily to the experience of Ubuntu users :)
Comment 9 Lennart Poettering 2009-01-14 11:32:16 EST
Nah, this is mostly an UI issue. PA can do digital amplification easily for you. You just have to set a positive dB volume for your device -- PA will do the right thing for you. The thing is now that the volume control UIs artificially limit the volume range upwards to 0dB. You can bypass that by using pacmd.

I have filed a bug requesting the extension of the volume slider in the new g-v-c for up to +60dB for sources. The full range will then be -60dB..+60dB. People with HDA cards that suffer by this problem may then set the digital amp factor to +20dB or any other value as they wish.
Comment 10 Samuel Audet 2009-01-15 08:19:46 EST
Oh really? This is good to know... thanks!

If I type "set-source-volume 1 0x17000" in pacmd, and then execute
   parec tmp.pcm
   pacat tmp.pcm
I _do_ get amplified sound! but it is annoyingly sort of distorted sound. If I try 0x20000, then I get complete white noise (it seems pulseaudio is incapable of saturating the sound wave and prefers to create noise.. bummer)

Also, any application using ALSA to record cannot record through pulseaudio... "arecord -f S16_LE -c2 -r44100" or "arecord -D pulse -f S16_LE -c2 -r44100" does nothing, it just stalls there, looking stupid :) And Skype just drops the call with no error messages or anything.. woops 

In my opinion, pulseaudio works pretty well for the playback side of things on Fedora, but recording is still very bad.. I don't think a GUI makeup alone will fix recordings issues.. :(
Comment 11 Lennart Poettering 2009-01-15 08:56:21 EST
For perfomance reasons we don't do saturation. Also, if we did you'd still have awful artifacts if we did. (But admittedly it might make sense to add saturation if amplification is actually a common case)

+20dB equals a volume setting of about 87500 (0x155CC). Setting the value to 0x17000 is already +27dB or so.
Comment 12 Samuel Audet 2009-01-15 09:06:02 EST
I see... on most laptop, or at least on mine (Dell XPS M1330), something around +30dB is pretty much standard to get normal volume for a person speaking in front of the laptop. Noise distortions get annoying with pulseaudio around that range, something I do not get with ALSA's softvol BTW
Comment 13 Samuel Audet 2009-01-18 01:57:24 EST
First, I must insist, but I believe an "official workaround" should be published so current users can actually _use_ Fedora, now, not in four months: This problem has already been lingering around since Fedora 8. The only known workaround that works on capture with Skype and what not is ALSA's softvol plugin... would it be possible to agree on a fix of this nature? Just a tiny patch to /etc/asound.conf (well after fixing alsa-lib so it doesn't crash on it) ?

However, in the long run, I also believe that everything should go through PulseAudio. It's just not ready yet. We need at least two-three things for this to happen: 
   1. An ALSA capture plugin that works
   2. Do saturation when amplification overflows (BTW, with SSE instructions doing this almost for free, I fail to see the problematic overhead.. ?)
   3. Update GUI mixers (pavucontrol, g-v-c, kmix, alsamixer, etc.) so they allow volume > 100%, and if that is not possible for an ALSA plugin, scale accordingly
Comment 14 Jaroslav Kysela 2009-01-20 07:14:31 EST
The alsa-lib-1.0.19-1 package should fix the segfault in the softvol plugin.

Also, for HDA hardware, you might play with hda-analyzer if low mic volume is not just a codec configuration problem (see www.alsa-project.org - Help to debug).
Comment 15 Samuel Audet 2009-01-22 00:30:58 EST
Great! thanks!

I'll check hda-analyzer, but I'm fairly sure that internal microphone on laptop computers usually don't have any analog mixers attached.. they are purely controlled digitally via software in the driver, AFAIK, and this is why ALSA's  "Digital Capture Volume" is important (for which PulseAudio does not currently provide a viable alternative). But I'll report anything interesting I find with hda-analyzer, thanks again
Comment 16 Samuel Audet 2009-01-23 23:58:32 EST
I looked at hda-analyzer, but I am unsure what I should be looking for... ? There did not seem to be interesting nodes in there that were not exposed properly as control devices.. Also, I did try all available models such as "3stack" and what not, but they only made less controls available than the default model...

In any case, I can confirm that softvol with alsa-lib-1.0.19-1 works just great. Now the fix is simple:
1. Update alsa-lib to 1.0.19-1, e.g.: "yum update" as root
2. Append the following to either "~/.asoundrc" or "/etc/asound.conf"

pcm.DigitalMic {
    @args [ CARD ]
    @args.CARD {
        type string
    }
    type asym
    capture.pcm {
        type softvol
        slave.pcm {
            @func concat
            strings [ "hw:" $CARD ]
        }
        control {
            name "Digital Capture Volume"
            card $CARD
        }
        min_dB -30.0
        max_dB  30.0
        resolution 121
    }
}

In the mixer GUI, make sure that "Digital Input Source" option is set to "Digital Mic". Then, in recording applications (*ugh* Skype *ugh*), select the "DigitalMic" device. After using it once, "Digital Capture Volume" or simply "Digital" should appear as a separate control in the mixer GUI, adjust it up, and from there everything should be fine... except this will not let you share the capture device, but I can live with this :)

BTW, I hope someone is thinking about this for the design of this here:
    http://fedoraproject.org/wiki/Releases/FeatureVolumeControl
Because, the way I see it, this problem will only get 100 times worse in Fedora 11, when the GUI mixer will not even expose ALSA controls anymore...
Comment 17 Matt Castelein 2009-01-27 20:00:55 EST
I have this extremely low mic volume on my HP laptop.. INTEL ICH6.
Comment 18 drapati 2009-02-08 17:43:05 EST
Thanks for posting the config. it works for me. I have a Thinkpad T61p with Fedora 10. I am getting some warning messages though from skype. Is there any way to get rid of them?

ALSA lib pcm_asym.c:106:(_snd_pcm_asym_open) playback slave is not defined
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL DigitalMic
ALSA lib pcm_asym.c:106:(_snd_pcm_asym_open) playback slave is not defined
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL DigitalMic
ALSA lib pcm_asym.c:106:(_snd_pcm_asym_open) playback slave is not defined
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL DigitalMic

RtApiAlsa: underrun detected.


RtApiAlsa: underrun detected.
Comment 19 Aniket 2009-02-14 14:39:21 EST
I modified my ~/.asoundrc as stated above and indeed in skype I can have a conversation without the need to scream!

But I noticed that in Gnome apps (like Gnome Sound Recorder and Empathy) to increase capture volume I have to go to "paman" pulse utility and increase the volume of the source device "alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0" to about 150% to get proper volume! But I am happy that it works now using this hack.

So I have finally reverted to using pulseaudio in KDE, as it enables me to use xine backend for phonon in turn which results in better performance with Amarokv2 .
Comment 20 thibaut.sardan 2009-02-22 10:33:27 EST
Thanks for the workaround with skype, using the ~/.asoundrc given above. But I still can't have a decent volume level in other Gnome application just like Gnome sound recorder.. what do you call "paman" and how do you open it ? I have all the volume control turned up... in volume manager..
Comment 21 Aniket 2009-02-23 14:16:54 EST
Hi all, 

I noticed one thing , this problem seems to be hardware specific. I got a new laptop a few days ago , its a Dell Studio XPS 13. Its an nVidia MCP79 chipset based motherboard and the sound card on it is the "nVidia Corporation MCP79 High Definition Audio [10de:0ac0] (rev b1)" and it has an integrated digital mic too, and I did not experience this bug with the new laptop. I have proper mic volume in Skype as well as all Gnome apps without doing any tricks. I am running Fedora 10 with all the latest updates. 

So according to me this bug seems to be more associated with the Intel ICH8/ICH7/ICH6 onboard sound cards as all the above posts point to Intel chipset based soundcards, may be Intel cards and pulseaudio dont play well together!! 

I may be wrong but can anyone else please test this on a non-Intel sound card and verify my findings.
Comment 22 thibaut.sardan 2009-02-23 19:30:31 EST
.. yes I know that !! of course does it come from the harware sound card !! it doesn't explain me how you did to make work Gnome apps and skipe together.. I noticed that if I play a video in firefox for example, I can't have any sound anymore from exaile or anything from Gnome. But if I play any song from Exail or from Gnome first, then I can't have any song from Firefox... that's another pulseaudio problem..
Comment 23 Aniket 2009-02-23 22:31:47 EST
Well, in gnome-sound-properties , keep the output device as autodetect. If you keep alsa or something there , you will have issues. Then, in skype keep output and ringing device as pulse. Keep input device as the device which is "below" "default"(it should be hw:Intel,0) . 

So start the paman utility just run paman from command line. If its not there , do "yum install paman" . That should work.
Comment 24 thibaut.sardan 2009-02-24 08:46:12 EST
All right thank you for the explanation, I had everything on autodetect for gnome-sound-properties, exept for sound Capture, which I put to HDA Intel... ALSA, and whatever I select it doesn't work, I don't have the autodetect available. For skype it works perfectly, but I guess that there is a probleme in pulsaudio because I can't play 2 sound (from Firefox from a flash video for instance and from exaile) at the same time. if I play anything from a flash video, I have to reboot X to be able to play Exaile.. that's just to much ! I installed pman but even with putting up a couple sound, it doesn't work better :(
Comment 25 thibaut.sardan 2009-02-24 09:23:47 EST
I realised that now even if I removed the ~/.asoundrc, I still have the Digital in Control Volume, and i am not able anymore to hear anything fom Exaile or any Gnome apps.. I have no more sound.. can anybody post me the result of the command 

rpm -qa | grep pulseaudio
Comment 26 Tim Taiwanese Liim 2009-02-25 02:46:46 EST
My audio (playback and recording) works reasonably well after
following Comment #16.

[timliim@yam ~]$ rpm -qa | grep pulseaudio
pulseaudio-utils-0.9.14-1.fc10.x86_64
pulseaudio-esound-compat-0.9.14-1.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
xine-lib-pulseaudio-1.1.16.2-1.fc10.x86_64
pulseaudio-0.9.14-1.fc10.x86_64
pulseaudio-libs-0.9.14-1.fc10.i386
pulseaudio-debuginfo-0.9.14-1.fc10.x86_64
pulseaudio-libs-zeroconf-0.9.14-1.fc10.x86_64
pulseaudio-libs-devel-0.9.14-1.fc10.x86_64
pulseaudio-libs-glib2-0.9.14-1.fc10.x86_64
pulseaudio-module-gconf-0.9.14-1.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-2.fc10.x86_64
pulseaudio-libs-0.9.14-1.fc10.x86_64
kde-settings-pulseaudio-4.1-6.20090206svn.fc10.noarch
pulseaudio-module-x11-0.9.14-1.fc10.x86_64
pulseaudio-core-libs-0.9.14-1.fc10.x86_64
Comment 27 thibaut.sardan 2009-02-25 08:08:29 EST
Thank's for you quick answer,

I resolved my probleme by deleting everything related to pulseaudio :

yum remove pulseaudio-utils.i386 pulseaudio-utils pulseaudio-libs-0.9.14-1.fc10.x86_64 pulseaudio-core-libs pulseaudio-debuginfo pulseaudio-esound-compat pulseaudio-libs-zeroconf pulseaudio-libs-devel pulseaudio-module-gconf alsa-plugins-pulseaudio pulseaudio-module-x11 alsa-lib-devel alsa-lib-debuginfo
Comment 28 'j 2009-06-05 15:28:58 EDT
(In reply to comment #27)
> Thank's for you quick answer,
> 
> I resolved my probleme by deleting everything related to pulseaudio :
> 
> yum remove pulseaudio-utils.i386 pulseaudio-utils
> pulseaudio-libs-0.9.14-1.fc10.x86_64 pulseaudio-core-libs pulseaudio-debuginfo
> pulseaudio-esound-compat pulseaudio-libs-zeroconf pulseaudio-libs-devel
> pulseaudio-module-gconf alsa-plugins-pulseaudio pulseaudio-module-x11
> alsa-lib-devel alsa-lib-debuginfo  

Thanks a lot, that worked great for me as well.
Comment 29 Chris Shoemaker 2009-06-09 12:05:04 EDT
I don't think removing pulseaudio fixes the problem this bug is about.
Was this really just a UI bug in gnome-volume-control? And if so, is it fixed now?
Comment 30 Bug Zapper 2009-11-18 04:37:49 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 Bug Zapper 2009-12-18 02:08:10 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 32 Jan Pazdziora 2009-12-26 16:53:01 EST
For the record, with Fedora 11 on my EEE PC 1000 using pulseaudio, microphone volume behaves properly, including Skype.
Comment 33 oliver 2010-06-09 06:35:47 EDT
Problem persists on Dell XPS M1330 with a current Fedora 13 as of today.  Can this issue be reopened?

Note You need to log in before you can comment on or make changes to this bug.