Bug 474711 - Fatal Exception upon reboot attempt after trying preupgrade from F9 to F10
Fatal Exception upon reboot attempt after trying preupgrade from F9 to F10
Status: CLOSED DUPLICATE of bug 473260
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
i586 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 17:45 EST by alauschke
Modified: 2014-01-21 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 13:53:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of fatal exception (1.34 MB, image/jpeg)
2008-12-04 17:45 EST, alauschke
no flags Details

  None (edit)
Description alauschke 2008-12-04 17:45:55 EST
Created attachment 325758 [details]
screenshot of fatal exception

Description of problem:
When trying to do the reboot after downloading and installing preupgrade, there is a fatal exception. I tried both methods described on 
http://howtoforge.com/how-to-upgrade-from-fedora-9-to-fedora-10-desktop-and-server
and both show the same problem upon reboot attempt. See screenshot.

Version-Release number of selected component (if applicable):
from 9 to 10 using preupgrade

How reproducible:
Well, just try the two methods described on that website. Just try to reboot after preupgrade has run, or the wget method.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
fatal exception

Expected results:
for sure not fatal exceptions, but the end result should be bootable F10 installation.

Additional info:
Very frustrating. There should never be fatal exceptions upon boot. No, my hardware is NOT broken!
Comment 1 Will Woods 2008-12-04 18:33:24 EST
It's hard to say from the attached image - I'd need to see the whole traceback / crash dump log to be sure - but what's visible matches the problem in bug 473260.

Does your Fedora 9 system use a swap file, by any chance?
Comment 2 alauschke 2008-12-04 18:44:56 EST
Yes, it does. During the install from CD/DVD the installer crashed several times, so I couldn't set up a swap partition, although that is recommended. Later on on the IRC #fedora group someone recommended to simply set up a swap file instead.
Comment 3 Will Woods 2008-12-05 13:53:55 EST
This is bug 473260, then. 

The simplest workaround seems to be to edit /etc/fstab and comment out the line for your swap file. Then reboot into the upgrade.

The upgrade should complete successfully, and then you can edit /etc/fstab again to restore your swap file.

*** This bug has been marked as a duplicate of bug 473260 ***
Comment 4 alauschke 2008-12-05 14:26:41 EST
I confirm that deleting the swap file entry in /etc/fstab allowed me to boot into F10. This is the solution the original poster Alexej Kutznetsov in 473260 found.

Note You need to log in before you can comment on or make changes to this bug.