Bug 474730 - Unplugging wacom tablet causes X server crash or hang
Unplugging wacom tablet causes X server crash or hang
Status: CLOSED DUPLICATE of bug 473767
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 19:43 EST by Ulrich Drepper
Modified: 2018-04-11 02:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 20:25:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2008-12-04 19:43:46 EST
Description of problem:
With F10, when I unplug my USB wacom tablet the X server crashes (session terminates) or it hangs with a black screen (probably also a crashed server, just not cleanly exiting).

This is with an Intel 965 chipset, in case it matters.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
kernel-2.6.27.5-117.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1.plug in USB wacom tablet
2.use it
3.unplug it
  
Actual results:
crashing server

Expected results:
no crash

Additional info:
Worked fine in F9.
Comment 1 Matěj Cepl 2008-12-05 11:32:44 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.


We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Peter Hutterer 2008-12-07 19:55:53 EST
Dupe of Bug #473767?
Comment 3 Ulrich Drepper 2008-12-07 20:25:59 EST
I updated linuxwacom to 0.8.0.3-6 and see no crashes anymore.  So, seems like a dupe.

*** This bug has been marked as a duplicate of bug 473767 ***

Note You need to log in before you can comment on or make changes to this bug.