Bug 474748 - apache crashes if apr_ldap not found
apache crashes if apr_ldap not found
Status: CLOSED DUPLICATE of bug 471898
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
: 475568 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 00:26 EST by scottf
Modified: 2009-01-22 09:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 09:36:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scottf 2008-12-05 00:26:18 EST
Description of problem:

Apache crashes (segfault) if apr_ldap not found.

Version-Release number of selected component (if applicable):

httpd-2.2.10-2.i386

How reproducible:

100% reproducible. Occurs everytime i try to retrieve subversion content hosted by apache by mod_dav_svn.

Steps to Reproduce:
1. configure mod_dav_svn and mod_authz_ldap
2. attempt to check out subversion content (
3. svn co http://server/svn/test

Actual results:

segfault.

Expected results:

no segfault and subversion client recieves data.

Additional info:

strace httpd -X 

returns this immediately prior to crash :

open("/usr/lib/apr-util-1/apr_ldap-1.so", O_RDONLY) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Reports on apache mailing lists of similar problem in apache 2.2.9. Patch is mentioned but does not appear to be included in 2.2.10.
Comment 1 scottf 2008-12-05 00:29:38 EST
/usr/lib/apr-util-1/ directory exists, is owned by apr-util-1.3.4-1.fc10.i386, but contains no files.

# rpm -ql apr-util
/usr/lib/apr-util-1
/usr/lib/libaprutil-1.so.0
/usr/lib/libaprutil-1.so.0.3.4
/usr/share/doc/apr-util-1.3.4
/usr/share/doc/apr-util-1.3.4/CHANGES
/usr/share/doc/apr-util-1.3.4/LICENSE
/usr/share/doc/apr-util-1.3.4/NOTICE
Comment 2 scottf 2008-12-05 00:39:57 EST
Installing apr-util-ldap avoids the problem, but apr-util-ldap was not automatically installed when i installed the RPMs that relied upon it.
Comment 3 Sergio Pascual 2008-12-09 12:59:00 EST
*** Bug 475568 has been marked as a duplicate of this bug. ***
Comment 4 Jim Garrison 2009-01-21 15:47:01 EST
Probably a dup of bug 471898
Comment 5 Joe Orton 2009-01-22 09:36:54 EST

*** This bug has been marked as a duplicate of bug 471898 ***

Note You need to log in before you can comment on or make changes to this bug.