Bug 474762 - system-config-network corrupts network settings
system-config-network corrupts network settings
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 03:48 EST by An. N
Modified: 2008-12-15 05:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 05:40:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description An. N 2008-12-05 03:48:22 EST
Description of problem:
After entering static IP data in system-config-network, saving it, and restarting the tool, the reported data is different from the one entered

Version-Release number of selected component (if applicable):
FC10 default

How reproducible:
Always

Steps to Reproduce:
1. start system-config-network
2. edit properties for eth0
3. select "statically set ip addresses"
4. enter address: 192.168.1.100, netmask 255.255.255.0, gateway 192.168.1.1
5. OK
6. file->save
7. file->quit
8. restart system-config-network
  
Actual results:
netmask is set to 192.168.1.1

If the network is restarted (/etc/init.d/...), the broadcast is set at 192.168.1.100 and the only route added is a route to the host itself (192.168.1.100) - which is nonsense.

Expected results:
255.255.255.0

Additional info:
Comment 1 Harald Hoyer 2008-12-05 04:06:36 EST
might be a duplicate of bug #469434
Comment 2 Harald Hoyer 2008-12-05 04:07:23 EST
system-config-network-1.5.94-2.fc10 has been pushed to the Fedora 10 testing
repository.  If problems still persist, please make note of it in this bug
report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You
can provide feedback for this update here:
http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10641
Comment 3 An. N 2008-12-05 18:47:13 EST
The updated network configurator seems to be ok.
Comment 4 Jiri Moskovcak 2008-12-15 05:40:40 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.