Bug 474774 - Probe details do not show neither graph nor event log
Probe details do not show neither graph nor event log
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.4
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike McCune
Miroslav Suchý
:
: 490361 (view as bug list)
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-12-05 06:08 EST by Miroslav Suchý
Modified: 2009-09-17 03:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-12-05 06:08:41 EST
Description of problem:
When you set up probe and see details, there is not shown neither event log nor graph. 
If I click "Download CVS data" I get correct data.

Version-Release number of selected component (if applicable):
spacewalk0.3+gitpatches

How reproducible:
always

Steps to Reproduce:
1. set up probe (e.g. ping to machine)
2. push scout config
3. wait till some data arrive
4. see detail of probe and check both "event log" and "graph"
  
Additional info:
In catalina.out is this Traceback:

2008-12-05 13:04:39,739 [TP-Processor8] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/rhn].[action] - Servlet.service() for servlet action threw exception
java.lang.NoSuchMethodError: org.jfree.data.time.TimeSeries.<init>(Ljava/lang/String;Ljava/lang/Class;)V
        at com.redhat.rhn.frontend.graphing.GraphGenerator.createDataset(GraphGenerator.java:156)
        at com.redhat.rhn.frontend.graphing.GraphGenerator.generateJFReeChart(GraphGenerator.java:114)
        at com.redhat.rhn.frontend.action.systems.monitoring.ProbeGraphAction.writeGraph(ProbeGraphAction.java:116)
        at com.redhat.rhn.frontend.action.systems.monitoring.ProbeGraphAction.execute(ProbeGraphAction.java:90)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
....
Comment 1 Miroslav Suchý 2009-03-03 06:15:46 EST
Hmm even the View as CVS stoped working now.
Comment 2 Mike McCune 2009-03-03 11:28:39 EST
crud.  looks like our graphing API doesn't work with Java 1.6
Comment 4 Mike McCune 2009-03-23 10:15:53 EDT
The fix for this was a rebuild of spacewalk-java using the correct version of jfreechart.  No code changes necessary.
Comment 5 Mike McCune 2009-03-23 17:19:52 EDT
ON_QA
Comment 6 Mike McCune 2009-03-25 13:55:34 EDT
*** Bug 490361 has been marked as a duplicate of this bug. ***
Comment 7 Jesus M. Rodriguez 2009-04-14 10:12:01 EDT
Spacewalk 0.5 released.
Comment 8 Miroslav Suchý 2009-09-17 03:08:49 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.