Bug 474902 - [LTC 5.4 FEAT] 4K Byte Sector HDDs Support (data disk) [201252]
[LTC 5.4 FEAT] 4K Byte Sector HDDs Support (data disk) [201252]
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All All
high Severity high
: alpha
: 5.4
Assigned To: Tom Coughlan
Red Hat Kernel QE team
: FutureFeature, OtherQA, TechPreview
Depends On:
Blocks: 445204 483701 483784 489593
  Show dependency treegraph
 
Reported: 2008-12-05 16:10 EST by IBM Bug Proxy
Modified: 2011-12-02 14:08 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
: 489593 (view as bug list)
Environment:
Last Closed: 2009-06-11 09:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50281 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-05 16:10:53 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201252]
a. Name of Feature:	4K Byte Sector HDDs Support
b. Feature Description
The SCSI core disk driver appears to already have support for multiple sector sizes. Tools,
filesystem and other driver updates may be required to ensure the 4K sector size HDDs function and
perform correctly. Will need to confirm when 4k sector HDDs are available for testing. Adding a new
4K drive to a system will be the same as adding a 512 byte sector drive.

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: 
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	unsure
g. Component Version Target:	Per code review, support for multiple sector sizes appears to be
available in 2.6.24. Will require validation.

3. Business Case
Drives with 4 kilobyte physical sectors will be making their way to the marketplace and the
expectation from customers will be the same as for 512 byte sectors.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Julio Alvarez, julioa@us.ibm.com
Comment 1 John Jarvis 2008-12-18 15:49:38 EST
IBM is signed up to test and provide feedback.
Comment 2 RHEL Product and Program Management 2009-02-16 10:18:50 EST
Updating PM score.
Comment 4 Ric Wheeler 2009-03-10 06:54:29 EDT
Note that we have uncovered multiple issues with our SAS testing - everything from lack of BIOS support for booting from the 4KB drive up to various boot utilities.

It would be great to get a board with BIOS support for this during our debug.
Comment 5 Tom Coughlan 2009-03-10 16:08:56 EDT
The last comment brings up a good point. Support for this is likely to be feasible first for non-boot, data disks. Boot support is likely to follow, because of BIOS issues, at a minimum. 

I will leave this BZ for the data disk part of the problem. This will remain targeted at 5.4, although at this point, it looks like it will be a tech. preview at best. I will clone another BZ, to focus on boot support. This will be targeted at 5.5. I imagine the same scenario will apply to RHEL 6.0 and 6.1 as well (Bug 463632).
Comment 6 Jim Meyering 2009-03-10 16:39:58 EDT
Partial fixes for this are on upstream parted's next branch.
Just today I've begun testing with real 4KB-sector hardware, and have found a new bug in that code (not surprising, since it wasn't close to completion).  Currently I plan to concentrate on getting robust support for gpt and msdos partition table formats.  dvh might be next, but if people have other favorites, please list them here.
Comment 7 Jesse Larrew 2009-04-14 16:22:26 EDT
The deadline for kernel code submissions is quickly approaching. Are the kernel portions of this BZ on track for the 4/23 kernel freeze? If you need help with testing, access to hardware, etc., just let me know. Thanks!

Jesse
Comment 8 John Jarvis 2009-06-11 09:28:07 EDT
Closing as WONTFIX for RHEL 5.4 due to lack of capacity, please feel free to
reopen to request this feature for consideration for RHEL 5.5
Comment 9 IBM Bug Proxy 2011-02-22 04:33:05 EST
------- Comment From  2011-02-22 04:28 EDT-------
We are reviewing this as a part of backlog bug clean up activity.
As per last comment closing this as WILL_NOT_FIX.
Please feel free to reopen once you have any valid update.

Thanks
Muni

Note You need to log in before you can comment on or make changes to this bug.