Bug 489593 - [LTC 5.4 FEAT] 4K Byte Sector HDDs Support (boot disk)
[LTC 5.4 FEAT] 4K Byte Sector HDDs Support (boot disk)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All All
high Severity high
: rc
: 5.5
Assigned To: Tom Coughlan
Red Hat Kernel QE team
: FutureFeature, OtherQA
Depends On: 474902
Blocks: 533192
  Show dependency treegraph
 
Reported: 2009-03-10 16:12 EDT by Tom Coughlan
Modified: 2009-11-05 10:14 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 474902
Environment:
Last Closed: 2009-10-01 16:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Coughlan 2009-03-10 16:12:04 EDT
+++ This bug was initially created as a clone of Bug #474902 +++

=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201252]
a. Name of Feature:	4K Byte Sector HDDs Support
b. Feature Description
The SCSI core disk driver appears to already have support for multiple sector sizes. Tools,
filesystem and other driver updates may be required to ensure the 4K sector size HDDs function and
perform correctly. Will need to confirm when 4k sector HDDs are available for testing. Adding a new
4K drive to a system will be the same as adding a 512 byte sector drive.

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: 
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	unsure
g. Component Version Target:	Per code review, support for multiple sector sizes appears to be
available in 2.6.24. Will require validation.

3. Business Case
Drives with 4 kilobyte physical sectors will be making their way to the marketplace and the
expectation from customers will be the same as for 512 byte sectors.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Julio Alvarez, julioa@us.ibm.com

--- Additional comment from jjarvis@redhat.com on 2008-12-18 15:49:38 EDT ---

IBM is signed up to test and provide feedback.

--- Additional comment from pm-rhel@redhat.com on 2009-02-16 10:18:50 EDT ---

Updating PM score.

--- Additional comment from coughlan@redhat.com on 2009-02-25 18:48:00 EDT ---

(In reply to comment #1)
> IBM is signed up to test and provide feedback.

That is critical, since as they indicated, the support is already theoretically there. There is no known work to be done. "Just" testing. 

I do consider this a risky feature for 5.4, even though we do have some of this hardware now. If there are any problems, or not enough capacity to test all the storage types, then we will punt this to 6.0.

Conditional NAK: PATCH for now.

--- Additional comment from rwheeler@redhat.com on 2009-03-10 06:54:29 EDT ---

Note that we have uncovered multiple issues with our SAS testing - everything from lack of BIOS support for booting from the 4KB drive up to various boot utilities.

It would be great to get a board with BIOS support for this during our debug.

--- Additional comment from coughlan@redhat.com on 2009-03-10 16:08:56 EDT ---

The last comment brings up a good point. Support for this is likely to be feasible first for non-boot, data disks. Boot support is likely to follow, because of BIOS issues, at a minimum. 

I will leave this BZ for the data disk part of the problem. This will remain targeted at 5.4, although at this point, it looks like it will be a tech. preview at best. I will clone another BZ, to focus on boot support. This will be targeted at 5.5. I imagine the same scenario will apply to RHEL 6.0 and 6.1 as well (Bug 463632).
Comment 1 Tom Coughlan 2009-10-01 16:20:20 EDT
Realistically, at this stage in the life of RHEL 5, it seems too late to try to add boot support for 4K disks. We should focus this effort on RHEL 6.

Note You need to log in before you can comment on or make changes to this bug.