Bug 474974 - Failure while trying to use NFS mount as base repository.
Failure while trying to use NFS mount as base repository.
Status: CLOSED DUPLICATE of bug 472462
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:f386e6d6dbb2b6b03...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 03:10 EST by Paul Wayper
Modified: 2009-12-30 20:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 16:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (74.43 KB, text/plain)
2008-12-06 03:10 EST, Paul Wayper
no flags Details
Attached traceback automatically from anaconda. (108.85 KB, text/plain)
2009-01-14 19:03 EST, Larry Boehm
no flags Details
Attached traceback automatically from anaconda. (171.26 KB, text/plain)
2009-01-29 04:50 EST, Rasmus Ory Nielsen
no flags Details
Attached traceback automatically from anaconda. (71.98 KB, text/plain)
2009-12-30 20:44 EST, jiminh07
no flags Details

  None (edit)
Description Paul Wayper 2008-12-06 03:10:51 EST
This bug was filed automatically by anaconda.
Comment 1 Paul Wayper 2008-12-06 03:10:58 EST
Created attachment 325974 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2008-12-08 10:03:27 EST
What's on your NFS server?  It looks like ISO images, but I don't know which ones you've got there.  From the log file, it looks like anaconda tried to find an ISO image that worked, didn't find any, and fell back to HTTP which then failed with the error message you see.
Comment 3 Paul Wayper 2008-12-09 05:47:52 EST
Yes, ISO images (in /opt/ftp/ISOs).

-rw-r--r-- 1 paulway users   3662573568 2008-11-26 10:07 Fedora-10-i386-DVD.iso
-rw-r--r-- 1 paulway users   4172283904 2008-11-26 12:27 Fedora-10-x86_64-DVD.iso

$ sha1sum /opt/ftp/ISOs/Fedora-10-*
086fd570518ac58d3966c43c1b6d146e38919d8d  /opt/ftp/ISOs/Fedora-10-i386-DVD.iso
f1e5ae7db6a1ba227de7294c4112385922388648  /opt/ftp/ISOs/Fedora-10-x86_64-DVD.iso

Both of these check out compared to the supplied SHA1SUM files.

I used File Roller to extract the boot.iso file from the x86_64 ISO and burnt it to a CD-RW.  Then I installed from there.

The first time I tried setting it to load from NFS share, it said it couldn't mount the directory (I can't remember the error message and foolishly forgot to write it down).  However, when I went to the command line on console 2, mount showed it mounted under /mnt/source.

I notice that it tried to look at both the Fedora 8 and 9 images - see lines:

08:02:24 WARNING : /mnt/source/Fedora-9-x86_64-DVD.iso doesn't have a install.img, skipping
08:02:24 WARNING : /mnt/source/Fedora-8-x86_64-DVD.iso doesn't have a install.img, skipping

in the traceback.  One possibility might be that it's looking for 'Fedora-?-x86_64-DVD.iso' files, maybe?

What other information would you like me to get?
Comment 4 Paul Wayper 2008-12-09 05:48:51 EST
Admittedly there are extra Fedora images from two previous versions - I keep them around in case I need to recover an older machine and there is some incompatibility between the old and the new.
Comment 5 Chris Lumens 2008-12-11 17:32:07 EST
Yes, we do look through all the ISO images in a given directory to try to find the right one.  You should be fine for now because no release before F10 had an install.img (it was called stage2.img in the past).  However you may wish to put the ISO images from different releases into different directories in the future, just to avoid any confusion.

It might even be worth testing that now, though I would be surprised if that fixed this issue.  I will try to set up a test in the next workday or two and see if I can reproduce this.  If so I likely won't need any more information.
Comment 6 Larry Boehm 2009-01-14 19:03:44 EST
Created attachment 329055 [details]
Attached traceback automatically from anaconda.
Comment 7 Rasmus Ory Nielsen 2009-01-29 04:50:29 EST
Created attachment 330339 [details]
Attached traceback automatically from anaconda.
Comment 8 Rasmus Ory Nielsen 2009-01-29 09:00:30 EST
I got the error when doing a dvd upgrade from f9. No nfs involved here.
However, I managed to do the upgrade in text mode.
Comment 9 Chris Lumens 2009-06-01 16:37:03 EDT

*** This bug has been marked as a duplicate of bug 472462 ***
Comment 10 jiminh07 2009-12-30 20:44:46 EST
Created attachment 381038 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.