Bug 47500 - GNU C extensions used in popt
Summary: GNU C extensions used in popt
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 47676 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-05 19:16 UTC by Nathan Owen
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 19:46:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple replacements for the non-standard libc functions (patch against rpm-4.0.3-0.57) (2.27 KB, patch)
2001-07-05 19:19 UTC, Nathan Owen
no flags Details | Diff

Description Nathan Owen 2001-07-05 19:16:56 UTC
Description of Problem:
The functions stpcpy and stpncpy are used in popt, and are not available on
non-glibc systems (at least they aren't on solaris 2.6)

Comment 1 Nathan Owen 2001-07-05 19:19:05 UTC
Created attachment 22808 [details]
simple replacements for the non-standard libc functions (patch against rpm-4.0.3-0.57)

Comment 2 Jeff Johnson 2001-07-05 19:46:36 UTC
There are copies of stpcpy/stpncpy in libmisc.a, so what's
really broken is that -lmisc needs to follow, not precede,
-lpopt when linking. That works for popt as a subdir of rpm,
but not for popt as a standalone library.

Adding symbols to libpopt as you have done will "work", but probably
should be done with a static to prevent further symbol clash down the
road.

Isn't legacy wonderful :-(

Comment 3 Jeff Johnson 2001-07-05 21:44:20 UTC
Fixed (by putting a static copy in popthelp.c) in my next checkin, should
be in rpm-4.0.3-0.58 or thereabouts.

Comment 4 Jeff Johnson 2001-07-06 13:59:42 UTC
*** Bug 47676 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.