Bug 47676 - rpm-4.0.3-0.57 missing -lmisc for some platforms
rpm-4.0.3-0.57 missing -lmisc for some platforms
Status: CLOSED DUPLICATE of bug 47500
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 09:53 EDT by Brian Harvell
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 09:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Harvell 2001-07-06 09:53:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-12smp i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
I got this error while compiling rpm on solaris 2.7. Looks like it's
missing a -lmisc since solaris does not have stp[n]cpy.

gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I/opt/bcs/include -Wall -g -O2
-D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes
-Wno-char-subscripts -c popthelp.c -o popthelp.o >/dev/null 2>&1
mv -f .libs/popthelp.lo popthelp.lo
/bin/sh ./libtool --mode=link gcc  -Wall -g -O2 -D_GNU_SOURCE -Wall
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts 
-o libpopt.la -rpath /opt/bcs/packages/rpm-4.0.3/lib  popt.lo findme.lo
poptparse.lo poptconfig.lo popthelp.lo  -L/usr/ucblib -R /usr/ucblib
rm -fr .libs/libpopt.la .libs/libpopt.* .libs/libpopt.*
/usr/ccs/bin/ld -G -h libpopt.so.0 -o .libs/libpopt.so.0.0.0  popt.lo findme.lo
poptparse.lo poptconfig.lo popthelp.lo  -R/usr/ucblib  -L/usr/ucblib -lc
(cd .libs && rm -f libpopt.so.0 && ln -s libpopt.so.0.0.0 libpopt.so.0)
(cd .libs && rm -f libpopt.so && ln -s libpopt.so.0.0.0 libpopt.so)
ar cru .libs/libpopt.a  popt.o findme.o poptparse.o poptconfig.o popthelp.o
ranlib .libs/libpopt.a
creating libpopt.la(cd .libs && rm -f libpopt.la && ln -s ../libpopt.la
libpopt.la)
gcc -DHAVE_CONFIG_H -I. -I. -I. -I.  -I/opt/bcs/include  -Wall -g -O2
-D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes
-Wno-char-subscripts -c test1.c
/bin/sh ./libtool --mode=link gcc  -Wall -g -O2 -D_GNU_SOURCE -Wall
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts 
-o test1 -all-static test1.o libpopt.la -L/usr/ucblib -R /usr/ucblib
gcc -Wall -g -O2 -D_GNU_SOURCE -Wall -Wpointer-arith -Wstrict-prototypes
-Wmissing-prototypes -Wno-char-subscripts -o test1 -static test1.o 
./.libs/libpopt.a -L/usr/ucblib -R/usr/ucblib
Undefined                       first referenced
 symbol                             in file
stpncpy                             ./.libs/libpopt.a(popthelp.o)
stpcpy                              ./.libs/libpopt.a(popthelp.o)
ld: fatal: Symbol referencing errors. No output written to test1
collect2: ld returned 1 exit status
make[4]: *** [test1] Error 1
make[4]: Leaving directory `/data/cvs/web-inf/bcs/BUILD/rpm-4.0.3/popt'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/data/cvs/web-inf/bcs/BUILD/rpm-4.0.3/popt'
make[2]: *** [all-recursive-am] Error 2
make[2]: Leaving directory `/data/cvs/web-inf/bcs/BUILD/rpm-4.0.3/popt'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/data/cvs/web-inf/bcs/BUILD/rpm-4.0.3'
make: *** [all-recursive-am] Error 2
Bad exit status from /tmp/rpm-tmp.21764 (%build)



How reproducible:
Always

Steps to Reproduce:
1.build on solaris
2.
3.
	

Additional info:
Comment 1 Jeff Johnson 2001-07-06 09:59:46 EDT

*** This bug has been marked as a duplicate of 47500 ***

Note You need to log in before you can comment on or make changes to this bug.