Bug 475025 - Xorg consumes near 100% CPU
Xorg consumes near 100% CPU
Status: CLOSED DUPLICATE of bug 474586
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 14:58 EST by Tom London
Modified: 2008-12-06 15:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 15:57:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log generated when Xorg is consuming all CPU (229.63 KB, text/plain)
2008-12-06 14:58 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2008-12-06 14:58:04 EST
Created attachment 326016 [details]
Xorg.0.log generated when Xorg is consuming all CPU

Description of problem:
After updating to today's rawhide, I notice that Xorg is consuming my CPU:

Tasks: 160 total,   1 running, 159 sleeping,   0 stopped,   0 zombie
Cpu(s): 22.3%us, 29.9%sy,  0.0%ni, 47.9%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   1973484k total,  1114432k used,   859052k free,    44968k buffers
Swap:  4063224k total,        0k used,  4063224k free,   314696k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 2637 root      20   0  441m  57m  11m S 96.4  3.0   5:46.68 Xorg               
 3401 tbl       20   0  906m 199m  28m S  3.0 10.4   0:45.76 firefox            
 3315 tbl       20   0  796m  58m  22m S  2.3  3.0   0:12.40 rhythmbox          
 3093 tbl        9 -11  363m 5640 4352 S  1.0  0.3   0:03.59 pulseaudio         
 3500 tbl       20   0 12992 1112  820 R  0.7  0.1   0:00.55 top                
  233 root      15  -5     0    0    0 S  0.3  0.0   0:00.04 ata/0              
 3153 tbl       20   0  165m 8008 4992 S  0.3  0.4   0:01.69 compiz             
    1 root      20   0  4092  868  608 S  0.0  0.0   0:02.08 init               
    2 root      15  -5     0    0    0 S  0.0  0.0   0:00.01 kthreadd           
    3 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 migration/0        
    4 root      15  -5     0    0    0 S  0.0  0.0   0:00.01 ksoftirqd/0        
    5 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 watchdog/0         
    6 root      RT  -5     0    0    0 S  0.0  0.0   0:00.09 migration/1        
    7 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/1        
    8 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 watchdog/1         
    9 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 events/0           
   10 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 events/1

System is Thinkpad X61 with Intel 965 graphics (/var/log/Xorg.0.log attached). 

I see no messages in ~/.xsession-errors, but I do see this in /var/log/messages:

Dec  6 11:38:06 tlondon kernel: [drm] Initialized drm 1.1.0 20060810
Dec  6 11:38:06 tlondon kernel: pci 0000:00:02.0: power state changed by ACPI to D0
Dec  6 11:38:06 tlondon kernel: pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Dec  6 11:38:06 tlondon kernel: [drm] Initialized i915 1.6.0 20080730 on minor 0
Dec  6 11:38:06 tlondon kernel: resource map sanity check conflict: 0xe0000000 0xefffffff 0xe0000000 0xe076ffff vesafb
Dec  6 11:38:06 tlondon kernel: ------------[ cut here ]------------
Dec  6 11:38:06 tlondon kernel: WARNING: at arch/x86/mm/ioremap.c:226 __ioremap_caller+0xc7/0x299()
Dec  6 11:38:06 tlondon kernel: Modules linked in: i915 drm sco bridge stp bnep l2cap bluetooth sunrpc nf_conntrack_netbios_ns ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table fuse dm_multipath kvm_intel kvm uinput snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss arc4 ppdev ecb iwlagn snd_mixer_oss iwlcore thinkpad_acpi sdhci_pci snd_pcm firewire_ohci i2c_i801 sdhci yenta_socket hwmon i2c_core firewire_core pcspkr rsrc_nonstatic crc_itu_t snd_timer mmc_core iTCO_wdt rfkill snd_page_alloc iTCO_vendor_support snd_hwdep mac80211 snd soundcore cfg80211 video parport_pc output battery parport ac e1000e sha256_generic cbc aes_x86_64 aes_generic dm_crypt [last unloaded: microcode]
Dec  6 11:38:06 tlondon kernel: Pid: 2637, comm: Xorg Not tainted 2.6.28-0.113.rc7.git5.fc11.x86_64 #1
Dec  6 11:38:06 tlondon kernel: Call Trace:
Dec  6 11:38:06 tlondon kernel: [<ffffffff81048c85>] warn_on_slowpath+0x58/0x7d
Dec  6 11:38:06 tlondon kernel: [<ffffffff81017b1b>] ? native_sched_clock+0x32/0x66
Dec  6 11:38:06 tlondon kernel: [<ffffffff81017b58>] ? sched_clock+0x9/0xc
Dec  6 11:38:06 tlondon kernel: [<ffffffff8136aaaf>] ? _read_unlock+0x26/0x2b
Dec  6 11:38:06 tlondon kernel: [<ffffffff81030b5b>] __ioremap_caller+0xc7/0x299
Dec  6 11:38:06 tlondon kernel: [<ffffffffa085ca5b>] ? i915_gem_entervt_ioctl+0x475/0x50c [i915]
Dec  6 11:38:06 tlondon kernel: [<ffffffff81030e1f>] ioremap_wc+0x1b/0x24
Dec  6 11:38:06 tlondon kernel: [<ffffffffa085ca5b>] i915_gem_entervt_ioctl+0x475/0x50c [i915]
Dec  6 11:38:06 tlondon kernel: [<ffffffffa0830cbb>] drm_ioctl+0x1dc/0x267 [drm]
Dec  6 11:38:06 tlondon kernel: [<ffffffff81190d05>] ? _raw_spin_lock+0x68/0x116
Dec  6 11:38:06 tlondon kernel: [<ffffffffa085c5e6>] ? i915_gem_entervt_ioctl+0x0/0x50c [i915]
Dec  6 11:38:06 tlondon kernel: [<ffffffff810e2385>] vfs_ioctl+0x5f/0x78
Dec  6 11:38:06 tlondon kernel: [<ffffffff810e2747>] do_vfs_ioctl+0x3a9/0x3db
Dec  6 11:38:06 tlondon kernel: [<ffffffff810e27ce>] sys_ioctl+0x55/0x77
Dec  6 11:38:06 tlondon kernel: [<ffffffff8101116a>] system_call_fastpath+0x16/0x1b
Dec  6 11:38:06 tlondon kernel: ---[ end trace 8bfb9eab5cc00b0b ]---
Dec  6 11:38:08 tlondon gdm-simple-slave[2634]: DEBUG(+): GdmSignalHandler: handling signal 10

[I get that kernel WARNING every boot, BZ'ed elsewhere.]

The nice gnome frequency scaling applet indicates max frequency as soon as gdm screen comes up.

Not sure its relevant, but these were included in today's updates:

Dec 06 10:04:22 Installed: kernel-2.6.28-0.113.rc7.git5.fc11.x86_64
Dec 06 10:45:00 Updated: 1:control-center-2.25.2-4.fc11.x86_64
Dec 06 10:42:46 Updated: xorg-x11-drv-synaptics-0.99.2-1.fc11.x86_64
Dec 06 10:42:48 Updated: setroubleshoot-plugins-2.0.11-2.fc11.noarch
Dec 06 10:42:49 Updated: xorg-x11-drv-ati-6.9.0-61.fc10.x86_64
Dec 06 10:39:38 Updated: libXi-1.2.0-1.fc11.i386
Dec 06 10:39:40 Updated: libXi-devel-1.2.0-1.fc11.x86_64
Dec 06 10:38:51 Updated: libXi-1.2.0-1.fc11.x86_64
Dec 06 10:12:32 Updated: glx-utils-7.2-0.14.fc10.x86_64
Dec 06 10:12:29 Updated: 1:gdm-user-switch-applet-2.25.1-2.fc11.x86_64
Dec 06 10:09:15 Updated: dbus-1.2.6-1.fc11.x86_64 (and friends)
Dec 06 10:09:10 Updated: mesa-libGL-devel-7.2-0.14.fc10.x86_64
Dec 06 10:09:11 Updated: mesa-libGLU-devel-7.2-0.14.fc10.x86_64
Dec 06 10:08:52 Updated: mesa-dri-drivers-7.2-0.14.fc10.x86_64
Dec 06 10:08:53 Updated: mesa-libGL-7.2-0.14.fc10.x86_64
Dec 06 10:08:53 Updated: mesa-libGLU-7.2-0.14.fc10.x86_64
Dec 06 09:54:51 Updated: compiz-gnome-0.7.8-7.fc11.x86_64


Version-Release number of selected component (if applicable):
xorg-x11-server-utils-7.4-3.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
xorg-x11-server-common-1.5.3-5.fc10.x86_64

I did try to "strace" Xorg process to see what it was doing, but that caused the system to freeze/lockup.  I had to power cycle to get back.

How reproducible:
Every boot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-12-06 15:08:10 EST
Also notice this segfault in /var/log/messages when I toggled desktop effects:

Dec  6 11:58:31 tlondon kernel: compiz[3153]: segfault at 3cc262ec10 ip 0000003cc262ec10 sp 00007fff3cac2508 error 14 in libstartup-notification-1.so.0.0.0[3cc5a00000+9000]
Comment 2 Yanko Kaneti 2008-12-06 15:42:58 EST
Perhaps a duplicate of bug 474586
Comment 3 Tom London 2008-12-06 15:57:26 EST
Yup.  Reverting gnome-screensaver fixes the problem.

Wouldn't have thought to look there....

Thanks.

*** This bug has been marked as a duplicate of bug 474586 ***

Note You need to log in before you can comment on or make changes to this bug.