Bug 474586 - GNOME screen saver 2.25.x causes 100% CPU load on idle system
GNOME screen saver 2.25.x causes 100% CPU load on idle system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
: 475025 475158 475204 475847 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 10:50 EST by Joachim Frieben
Modified: 2015-01-14 18:22 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 16:36:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-12-04 10:50:24 EST
Description of problem:
After updating to gnome-screensaver-2.25.1-2.fc11.x86_64, Xorg suddenly grabs almost 100% of CPU load on an otherwise idle system.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.25.1-2.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Update to GNOME screen saver 2.25.1.
2. Start new GNOME session.
3. Execute "top" command in a shell.
  
Actual results:
Xorg consumes about 100% of CPU load.

Expected results:
Xorg consumes a low 1 digit percentage of CPU load.

Additional info:
- Reverting to package gnome-screensaver-2.24.1-2.fc11.x86_64 restores proper
  operation.
- Please prevent gnome-screensaver-2.25.1-2.fc11.x86_64 from entering the
  "rawhide" repository as it is not obvious to nail down this issue.
  The CPU load is not caused by GNOME screen saver itself but only indirectly
  through the Xorg binary.
Comment 1 jmccann 2008-12-04 12:42:35 EST
Yes, this is a known problem.  Hoping that ajax can shed some light on this for us.

A minimal test case for this is:
http://svn.gnome.org/viewvc/gnome-screensaver/trunk/src/test-idle-ext.c?view=markup
Comment 2 Tom London 2008-12-06 15:57:26 EST
*** Bug 475025 has been marked as a duplicate of this bug. ***
Comment 3 jmccann 2008-12-08 11:37:00 EST
*** Bug 475204 has been marked as a duplicate of this bug. ***
Comment 4 Steve 2008-12-09 13:04:03 EST
*** Bug 475158 has been marked as a duplicate of this bug. ***
Comment 5 Pete Zaitcev 2008-12-10 19:45:57 EST
*** Bug 475847 has been marked as a duplicate of this bug. ***
Comment 6 Steve 2008-12-11 04:07:43 EST
Where can I get gnome-screensaver-2.24.1-2.fc11?
Comment 8 Fedora Update System 2008-12-12 12:00:05 EST
xorg-x11-server-1.5.3-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.3-6.fc10
Comment 9 Steve 2008-12-12 12:57:18 EST
Great, and it works!(In reply to comment #8)
> xorg-x11-server-1.5.3-6.fc10 has been submitted as an update for Fedora 10.
> http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.3-6.fc10

High cpu usage is gone, but the gnome-screensaver is only presentig black screen.
Comment 10 Fedora Update System 2008-12-13 09:56:28 EST
xorg-x11-server-1.5.3-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11200
Comment 11 Steve 2008-12-13 10:20:55 EST
(In reply to comment #10)
> xorg-x11-server-1.5.3-6.fc10 has been pushed to the Fedora 10 testing
> repository.  If problems still persist, please make note of it in this bug
> report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can
> provide feedback for this update here:
> http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11200

Same as before; no more high cpu usage, but only black screen available.
Comment 12 Joachim Frieben 2008-12-13 19:55:54 EST
Bug resolved by xorg-x11-server-1.5.3-6.fc10.x86_64. No "black screen" issue with gnome-screensaver-2.25.1-2.fc11.x86_64 on the system for which the bug had been reported.
Comment 13 Steve 2008-12-14 02:52:39 EST
The only screensaver that is working is floating fedora bubbles.

xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-server-common-1.5.3-6.fc10.i386
gnome-screensaver-2.25.1-2.fc11.i386
xorg-x11-drv-radeonhd-1.2.4-1.1.20081212git.fc11.i386
Comment 14 Joachim Frieben 2008-12-14 04:58:07 EST
(In reply to comment #13)
> The only screensaver that is working is floating fedora bubbles.
> xorg-x11-drv-radeonhd-1.2.4-1.1.20081212git.fc11.i386

But then that's a different bug. Here, everything is working nicely including OpenGL screen savers using xorg-x11-drv-ati-6.9.0-62.fc10.x86_64. The present bug addressed high system load caused by g-s-s and X.
Comment 15 Matěj Cepl 2008-12-16 09:05:03 EST
*** Bug 475890 has been marked as a duplicate of this bug. ***
Comment 16 Steve 2008-12-16 09:56:37 EST
(In reply to comment #14)
> (In reply to comment #13)
> > The only screensaver that is working is floating fedora bubbles.
> > xorg-x11-drv-radeonhd-1.2.4-1.1.20081212git.fc11.i386
> 
> But then that's a different bug. Here, everything is working nicely including
> OpenGL screen savers using xorg-x11-drv-ati-6.9.0-62.fc10.x86_64. The present
> bug addressed high system load caused by g-s-s and X.

Yes, it's here:
https://bugzilla.redhat.com/show_bug.cgi?id=476417
Comment 17 Donald Cohen 2008-12-16 18:29:03 EST
 yum --enablerepo=updates-testing update xorg-x11-server
=> cannot retrieve repository metadata
/etc/yum.ym.repos.d contains no updates-testing but does contain fedora-updates-testing, but
 yum --enablerepo=fedora-updates-testing update xorg-x11-server
=> error getting repository data for fedora-updates-testing, repository not found
Comment 18 Fedora Update System 2008-12-17 19:39:08 EST
xorg-x11-server-1.5.3-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Todd Newell 2008-12-22 16:10:52 EST
While not 100%, Xorg still shows a pretty much constant use of 10.3% of the CPU.  Occasionally the usage will drop to something like 4.3%, but then returns back to 10.3%.  When there is screen activity, such as scrolling the Firefox browser window, or even just moving the mouse arrow around, the CPU usage for Xorg shoots upward.  In the case of the scrolling browser window, CPU usage jumps up above 80%.

I have:
Fedora 10 (32 bit)
kernel-PAE-2.6.27.7-134.fc10.i686
xorg-x11-server-Xorg-1.5.3-6.fc10.i386
xorg-x11-drv-ati-6.9.0-62.fc10.i386
gnome-screensaver-2.24.1-1.fc10.i386

Please let me know what other pertinent information I can provide.  Thanks.
Comment 20 Steve 2008-12-22 16:46:03 EST
Please reopen this bugreport. The bug is back again. Gnome-screensaver is using 100% of cpu. By killing the screensaver, cpu goes back to normal state.

gnome-screensaver-2.25.2-1.fc11.i386
xorg-x11-server-Xorg-1.5.99.3-1.fc11.i386
Comment 21 Joachim Frieben 2008-12-23 05:21:22 EST
Reopening as of comment #3. I am currently using F10 again and unable to confirm the regression.
Comment 22 Steve 2008-12-23 10:20:49 EST
The problem is fixed in xorg-x11-server-Xorg-1.5.99.3-2.fc11.i386.
Comment 23 Pete Zaitcev 2008-12-26 00:49:59 EST
At last seems to work ok with:
gnome-screensaver-2.25.2-1.fc11.x86_64
xorg-x11-server-Xorg-1.5.99.3-4.fc11.x86_64
As far as I'm concerned, safe to close.
Comment 24 Cristiano Duarte 2009-02-19 12:12:37 EST
The "Bug 475890 - /usr/bin/X using 100% of cpu" was marked as a duplicate and it isn't.

Please reopen that BUG since it has nothing to do with gnome-screensaver. I'm using a KDE only desktop and applications and I still experience this bug on fedora-rawhide (last yum update: 2009-02-19). Since I have 4-core CPU, the computer does not freeze, I can still use it normally (I don't know if the fact that I can't use CRTL+ALT+Fn has something to do with this...).

kernel-2.6.29-0.124.rc5.fc11.x86_64
kdelibs-4.2.0-11.fc11.x86_64
xorg-x11-server-Xorg-1.5.99.902-12.fc11.x86_64
kdeplasma-addons-4.2.0-1.fc11.x86_64
...

More info look at "Bug 475890 - /usr/bin/X using 100% of cpu".

Note You need to log in before you can comment on or make changes to this bug.